Closed (works as designed)
Project:
Display Suite
Version:
7.x-2.x-dev
Component:
Code
Priority:
Major
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
16 Apr 2012 at 16:09 UTC
Updated:
30 Jul 2013 at 15:28 UTC
When I try to edit Display Suite code field, I encounter following error (it happens also in 7.x-1.x-dev):
Additional uncaught exception thrown while handling exception.
Original
PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away: SELECT lid, location FROM {locales_source} WHERE source = :source AND context = :context AND textgroup = 'default'; Array ( [:source] => Edit [:context] => ) in _locale_parse_js_file() (line 1557 of C:\data\www\knihovna\includes\locale.inc).
Additional
PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away: INSERT INTO {watchdog} (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2, :db_insert_placeholder_3, :db_insert_placeholder_4, :db_insert_placeholder_5, :db_insert_placeholder_6, :db_insert_placeholder_7, :db_insert_placeholder_8, :db_insert_placeholder_9); Array ( [:db_insert_placeholder_0] => 1 [:db_insert_placeholder_1] => php [:db_insert_placeholder_2] => %type: !message in %function (line %line of %file). [:db_insert_placeholder_3] => a:6:{s:5:"%type";s:12:"PDOException";s:8:"!message";s:248:"SQLSTATE[HY000]: General error: 2006 MySQL server has gone away: SELECT lid, location FROM {locales_source} WHERE source = :source AND context = :context AND textgroup = 'default'; Array ( [:source] => Edit [:context] => ) ";s:9:"%function";s:23:"_locale_parse_js_file()";s:5:"%file";s:40:"C:\data\www\knihovna\includes\locale.inc";s:5:"%line";i:1557;s:14:"severity_level";i:3;} [:db_insert_placeholder_4] => 3 [:db_insert_placeholder_5] => [:db_insert_placeholder_6] => http://knihovna.litomysl.cz/admin/structure/ds/fields/manage_custom/narozeni_a_umrti [:db_insert_placeholder_7] => http://knihovna.litomysl.cz/admin/structure/ds/fields [:db_insert_placeholder_8] => 158.194.138.202 [:db_insert_placeholder_9] => 1334586532 ) in dblog_watchdog() (line 157 of C:\data\www\knihovna\modules\dblog\dblog.module).
Fatal error: Exception thrown without a stack frame in Unknown on line 0
It worked before, so it might have to do something with my environment. Feel free to educate me. Thanks.
Comments
Comment #1
swentel commentedWell, the error says your mysql version has gone away, for reasons that I can't tell you from where I am. But this has nothing todo with Display Suite at all.
Comment #2
milos.kroulik commentedThanks. But MySQL connection works in all other area of Drupal, which seems suspicious to me.
Comment #3
swentel commentedThat's weird indeed, however, I have no clue how I could reproduce this. Maybe it depends on the data you're trying to add into the form, because, as I say, it works perfectly fine here for me and all of my colleagues. (resetting status, it reflects it better).
Comment #4
milos.kroulik commentedWell, it doesn't depend on output, as I can't edit anything. I will try to do some research and get back, if there will be any findings.
Comment #5
swentel commentedThere might be one thing and that is you upgraded from 7.x-1.x to 7.x-2.x. In that case, that's not possible at all.
Comment #6
swentel commentedIn case you upgraded, the ds_fields table misses the 'ui_limit' column, that's why it fails.
Comment #7
swentel commentedComment #8
milos.kroulik commentedNo, the problem is same on 7.x-1.x. And you are probably right, that it doesn't have much in common with DS. Thanks.
Comment #9
milos.kroulik commentedSorry
Comment #10
milos.kroulik commentedIt is solved by setting max_allowed_packet=100M in my.ini on hosting.
Comment #11
rpmskret commentedI have encountered this error several times on different drupal sites recently. And again for a new one today. Thank you for this post and the solution which also works for my test server, XAMPP type on windows 7.
I set the max_allowed_packet=32M in my.ini. It had been at the default of 1M.
@swentel, compliments to you for your incredible activity level with ds, including the support attention shown here.
Comment #12
libruce commentedThanks for the post.
It is solved by adding setting max_allowed_packet=100M in my.ini on hosting.
Comment #13
wOOge commentedI was getting a similar error when editing a custom code field. Turning off the Toolbar module worked for me.
Comment #14
joehudson commentedincreasing max_allowed_packet to 8M worked for me. The issue occurred rfor adding a new content type right after installing Display Suite and Field Group modules.
Comment #15
dongtian commentedThanks a lot.
After set the max_allowed_packet = 32M, I can access my site again on Wamp.
Comment #16
stongo commentedThis fixed this issue for me, as well. But a word of warning, make max_allowed_packet the lowest size possible. setting it too high is asking for trouble :)