Closed (won't fix)
Project:
Drush
Version:
8.x-6.x-dev
Component:
Core Commands
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Issue tags:
Reporter:
Created:
20 Oct 2011 at 09:28 UTC
Updated:
11 Sep 2013 at 05:06 UTC
I can download a new project fine for a Drupal 5 site. But calling drush en xxxxx results in a PHP fatal error:
Fatal error: Call to undefined function update_check_incompatibility() in /usr/share/drush-4.5/drush/commands/pm/pm.drush.inc on line 611
Call Stack:
0.0021 198720 1. {main}() /usr/share/drush-4.5/drush/drush.php:0
0.0422 3238920 2. drush_main() /usr/share/drush-4.5/drush/drush.php:41
1.9843 65231216 3. drush_dispatch() /usr/share/drush-4.5/drush/drush.php:101
1.9846 65232496 4. call_user_func_array() /usr/share/drush-4.5/drush/includes/command.inc:214
1.9846 65233272 5. drush_command() /usr/share/drush-4.5/drush/includes/command.inc:0
1.9854 65243520 6. _drush_invoke_args() /usr/share/drush-4.5/drush/includes/command.inc:806
1.9863 65277128 7. call_user_func_array() /usr/share/drush-4.5/drush/includes/command.inc:134
1.9863 65277904 8. drush_pm_enable() /usr/share/drush-4.5/drush/includes/command.inc:0
This happens when enabling any Drupal 5 module since upgrading to Drush 4.5
Comments
Comment #1
NATech commented+1
Got the same thing happening exactly -
Error: Call to undefined function update_check_incompatibility() in /usr/local/share/drush/commands/pm/pm.drush.inc, line 611
One cluge you can do, is to comment out the block starting at line 611, through line 619.
I'm sure that's not the best solution, but it does seem to work.
Comment #2
jameswoods commentedI had the same error, but with enabling Drupal 7 modules. I ended up deleting the entire drush directory, then re-extracting the drush tarball...now everything is working great. I dunno what was causing it.
Comment #3
greg.1.anderson commentedThis issue was marked
closed (won't fix)because Drush has moved to Github.If desired, you may copy this bug to our Github project and then post a link here to the new issue. Please also change the status of this issue to
closed (duplicate).Please ask support questions on Drupal Answers.