OS: FreeBSD 8.2-STABLE
Web server: Apache 2.2.31
PHP: 5.6.23
Database: MySQL Ver 14.14 Distrib 5.6.23
Drupal: 8.1.7
General Web environment: Hosted, shared (multi-customer) server

Repeatable:
1. Display of error: Always
2. Configuration to cause root error condition: Unknown

Steps to repeat display of error:
1. Install Drupal as a multi-site installation (not using sites/default)
2. Configure a site (A) file system to use the download method "Public local files served by the webserver"
3. Verify site A has a writable files directory
4. Remove a different site (B)
5. View the Status Report on site A
(There may be additional steps between 3 and 5 to reach the error state.)

Expected Results:
The site A Status Report shows that the files directory is writable.

Actual Results:
The site A Status Report shows that the files directory is not writable and displays a file path from the now-deleted site B, e.g.:

The directory sites/site_cbooks/files/config_sHv7c2RCZubBwVkuleCzX1UWwUNMf3PMq3D7YZr0VakHeHy75m_0z9ahdMKfs-9JfFSR-FaMpw/sync does not exist. You may need to set the correct directory at the file system settings page or change the current directory's permissions so that it is writable.

The file system settings page linked from the error message makes no reference to the file path in the error message; instead, it refers to the correct site's file path.

Comments

jppi_Stu created an issue. See original summary.

jppi_Stu’s picture

Version: 8.1.7 » 8.1.10
Priority: Normal » Major

I believe the priority on this should be raised because this becomes a blocking problem when trying to update the site. The update script checks for problems and does not allow a site to update when this "problem" is "detected." This, in turn, prevents installation of security updates, making this indirectly a security problem.

jppi_Stu’s picture

Version: 8.1.10 » 8.2.6
Priority: Major » Normal

After looking on the Web for more information about the "sync" directory I found that this is defined in the settings.php file for each site in the multi-site install. For the affected site, the wrong site directory was referenced in the $config_directories['sync'] value. After editing that file manually to point to the correct site, the error was resolved.

This does not answer how the incorrect value (site directory) appeared in that variable value to begin with, but as it is easy to fix -- once one knows how -- I will assume this to be "normal" priority after all. And perhaps it will eventually be closed as something that can't be reproduced.

cilefen’s picture

Version: 8.2.6 » 8.3.x-dev
Component: file system » configuration system
Status: Active » Closed (cannot reproduce)

While you commented I was typing:

Huh? What's going on here? Could you get into detail about the remove site B step? Are you sure each site is using the expected settings.php file. This makes no sense.

It seems like a settings.php may have been copy/pasted? If you can reliably reproduce this, reopen it.

xjm’s picture

Issue tags: +DrupalCampNJ2017