The Data/Schema module worked well on my localhost, but when I committed the Data module to another drupal site, all Data UI menues fails (adopt /view records / export) with nothing written to watchdog.

The following error message is written as plain text when clicking on any Data UI menu item:

Input value "admin" is not within allowed value list
Input "format" is not within allowed value list or of illegal datatype
Input value "structure" is not within allowed value list
Input "content_type" is not within allowed value list or of illegal datatype
Input value "data" is not of type "numeric"
Input "limit" is not within allowed value list or of illegal datatype
Input value "adopt" is not of type "numeric"
Input "page" is not within allowed value list or of illegal datatype
format and content_type are mandatory input parameters which also must be assigned allowed values

Have anyone encountered a such error message and know what causes it?
Is it a Data module, Schema module or is it caused by a LAMP-configuration setting?

Comments

Harald’s picture

Status: Active » Fixed

Solved.

Error was generated by Apache-settings, because the URLs used by the module (*/data/*) conflicted with mod_rewrite-settings.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.