Hi, here is my full error

An AJAX HTTP error occurred.
HTTP Result Code: 500
Debugging information follows.
Path: /admin/structure/views/view/frontpage/enable?token=pzxI9BcarwxxoEc9DkZKm0yxs6eElfACz3JC7mPKLL8
StatusText: Service unavailable (with message)
ResponseText: PDOException: SQLSTATE[HY000]: General error: 1267 Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '=': SELECT s.uid, c.updated FROM {ctools_object_cache} c INNER JOIN {sessions} s ON c.sid = s.sid WHERE s.sid <> :session_id AND c.obj = :obj AND c.name = :name ORDER BY c.updated ASC; Array
(
[:session_id] => vu4W8YRvjgKVte2bWsNHUzIZBjK5nYwbtG-GXnz5P6M
[:obj] => view
[:name] => frontpage
)
in ctools_object_cache_test() (line 145 of /home/motwmud/public_html/nightweavermaille.com/sites/all/modules/ctools/includes/object-cache.inc).

This is the line in question:

 return db_query('SELECT s.uid, c.updated FROM {ctools_object_cache} c INNER JOIN {sessions} s ON c.sid = s.sid WHERE s.sid <> :session_id AND c.obj = :obj AND c.name = :name ORDER BY c.updated ASC', array(':session_id' => $sid, ':obj' => $obj, ':name' => $name))
    ->fetchObject();

I have had this issue in two installations. The above error is a basic 7.12 install using my control panel and fantastico with ctools and views dev vrs installed. My other install is a manual upgrade to 7.14 with a number of other mods installed. I had the recommended vrs then uninstalled and went to dev vrs after reading through numerous issues/bug reports. I've also checked my database and can see nothing wrong with the tables and the utf8_general/unicode. All of my tables are utf8_general. I'm not a true coder so i'm at a loss at this point if i'm doing something wrong or there is a bug.

Comments

lemdeals’s picture

Hi friend,

I have the same issue that you are reporting in this space, please could you tell me if you have been solved it. I'll appreciate if you can share the solution.

Thanks
Luis

merlinofchaos’s picture

Status: Active » Closed (won't fix)

The illegal mix of collations is 99.999% always a local problem, where somehow your tables got created with different collations. Once this happens, you can't join the tables together. I don't understand how this happens, usually it means that somehow the defaults got changed, or a set of tables got changed ignoring the defaults.

Either way, what you have to do is google search on how to find and set your collations nad make sure that the tables involved have the same collation. Typically Drupal expects to use utf8_general_ci.

lemdeals’s picture

Thanks my frinds, I am going to follow your suggest.

Luis