When attempting to verify a site in Aegir after upgrading an environment from PHP 7.0 to PHP 7.2, the following error is shown:
Drush command terminated abnormally due to an unrecoverable error. Error: Declaration of RulesConditionalEmptyUI::form(&$form, &$form_state, $options = Array) must be compatible with RulesContainerPluginUI::form(&$form, &$form_state, $options = Array, $iterator = NULL) in /var/aegir/platforms/drupal-7.58/sites/SITE/modules/rules_conditional/includes/rules_conditional.ui.inc, line 56
This occurs on the newest 7.x-2.x-dev of Rules which already includes the patch from #2923477: PHP 7.x compatibility issue. I'm also on the newest 7.x-1.x-dev of Conditional Rules.
Comments
Comment #2
nwom commentedComment #3
nwom commentedComment #4
nwom commentedHere is a patch that should fix this. Please review.
Comment #5
marcoka commentedthank you. no errors no more. without that patch its also impossible to deactivate that module.
if you delete it manually you will get more problems.
very important patch. also needed fpr just removing the module!
Comment #6
alansaviolobo commented+1 reviewed
Comment #7
akolahi commentedWorks
Comment #9
alansaviolobo commentedComment #10
nwom commented@alansaviolobo: Why would I not get commit credit?
Comment #11
alansaviolobo commentedYou have been given credit.
Comment #12
nwom commentedThat is credit for creating or being active in an issue. Instead there is a separate commit credit, as you can see at the bottom of any Drupal profile.
It's not a huge deal, but for people like me that are slowly starting to create patches for the community, it would be nice to have the commit credit.
Comment #13
alansaviolobo commentedYour are already credited on your profile ( as per the black arrow).
But, as I understand it, you would like that entry at the red arrow ?
If I am not mistaken, for this to happen, I would have to give you repo access and you would have make to commit.
Comment #14
nwom commented@alansaviolobo: Nope, I don't need repo access. All of the other commits that were credited to me, were done by whoever closed the issue. This is sadly out of my area of expertise (since I have never been a module maintainer).
Again, it's not a huge deal, but would definitely be nice for you to know how to do in the future, for others like me that enjoy that "+1" on their profile.
Comment #15
tr commented@alansaviolobo:
If you use the git command listed at the very bottom of this page, then it assigns authorship properly:
git commit -m 'Issue #2959426 by NWOM, alansaviolobo: Incompatibility with PHP 7.2' --author="git <git@603482.no-reply.drupal.org>"The key part is the --author option. drupal.org populates that option with the e-mail address that the patch author has set up on his/her account. NWOM appears to have this set as "git ".
Comment #16
nwom commented@TR: Thank you. I'll take note of that for the future, since I am meaning to create my first module soon.
Comment #17
tr commented@NWOM, (and @alansaviolobo too!): Feel free to pm me if you have any questions about maintaining modules.
Comment #18
alansaviolobo commentedThanks @TR
I usually just take the text from the "Message Only" section rather than "Git Command" section and use my IDE to make the commit. that is how the author part got skipped. have taken a note of it.
Comment #19
nwom commented@TR Thank you for the offer. I'll definitely keep that in mind! :)
Comment #21
mdmanouwer commentedthanks above patches when i applied to my repository fixed my issue
.
let me know if any body have issue on
applying patches
email me mdmanouwer@gmail.com
Comment #22
graysonecooper commentedI'm still getting this error (on running update.php; otherwise 500 error for all pages on my site) on upgrading to php7.2. Backing down to php7.1 resolves. All modules/core is updated to recent, and Rules Conditional is 7.x-1.0-beta2.
It seems that this patch has been committed and included in the latest stable release, but wanted to check if I was missing something.
Thanks for all the hard work in getting things ready to go for php5.6 EOL!
Comment #23
aytee commentedUpdating to 7.x-1.x-dev solved the problem for me. Thanks!
Comment #24
howdytom commented#4 worked liked a charm. Thanks a lot!
Comment #25
massiws commentedUpdating to 7.x-1.x-dev solved the problem for me too.
Is there any reason to remain in beta?
Thanks.
Comment #26
marco aurelio rocca commentedDidn't get solution using DEV. :(
Got it with an extra pach, other than #4. Can anyone help checking?
Comment #27
bessonweb commented#4 Worked well ! Thanks for the patch.
Comment #28
zlatev commentedEncountered the same issue on 7.x-2.10
The patch from https://www.drupal.org/project/rules_conditional/issues/2959426#comment-... resolves the problem but it should be applied from docroot and if you are using a profile or other structure this is an issue. Posting a patch which can be applied from module root folder.
Comment #29
alansaviolobo commentedThe patch provided in #26 appears to be for the Rules and not the Rules Conditional Module.
Check PHP 7.x compatibility issue
Comment #30
aswathyajish commentedThanks. Patch in #4 worked for me.