• Advisory ID: DRUPAL-SA-2008-042
  • Project: Tinytax taxonomy block (third-party module)
  • Version: 5.x
  • Date: 2008-July-2
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross site scripting


The Tinytax taxonomy block displays a vocabulary as a tree within a block.

The module displays certain values without appropriate filtering. Malicious users with the permission to create taxonomy terms are able to exploit this issue and insert arbitrary HTML and script code into pages. Such a cross site scripting attack (XSS) may lead to the malicious user gaining administrator access.

Versions affected

  • Tinytax taxonomy block for Drupal 5.x prior to 5.x-1.10-1.

Drupal core is not affected. If you do not use the contributed Tinytax taxonomy block module, there is nothing you need to do.


Install the latest version:

See also the Tinytax taxonomy block project page.

Reported by

  • The cross site scripting issue was reported by the module maintainer, Simon Rycroft.


The security contact for Drupal can be reached at security at drupal.org or via the form at http://drupal.org/contact and by selecting the security issues category.