Download panopoly-7.x-1.33-core.tar.gztar.gz 20.17 MB
MD5: 4fda2ba36f39256f59c96fbb31b964d8
SHA-1: 78b176b76887476c1730888fedd407b6c3f9083e
SHA-256: e495ecd65748a10fb116059ccde1d4774dbf630f7917760556d1d7ae5a373fb0
Download panopoly-7.x-1.33-core.zipzip 23.16 MB
MD5: f58ef5c97cb4782fb90aa050e35b7f95
SHA-1: 8d41de04402ac21e7fe090ef21094e8d07834c7e
SHA-256: 8b185f5ea367164ad8adafaccf135d9d5aafbfdd8d6ae399bc54a375dae7acb3
Download panopoly-7.x-1.33-no-core.tar.gztar.gz 17.01 MB
MD5: 05fa703b8f94dbd2037407560239dc58
SHA-1: a9fe5ef277fda283705c140c07deb533696628ba
SHA-256: c3ad89a5ce33dc2a7baa14b29c8e891d22347f5b24e7c2f08fefe70f973d5d4e
Download panopoly-7.x-1.33-no-core.zipzip 19.29 MB
MD5: eaa469ed2fb895cda9878d8de5d7d08b
SHA-1: af45595ae6c8bda10853e81878f76a42d9a264c2
SHA-256: c2e1bf9543583062173cd437615193136ff125d93da10568b692cdc2236dcaf7
Download panopoly-7.x-1.33.tar.gztar.gz 263.37 KB
MD5: 84ce65ad4aa1ed96a8ce15282d7bb8b1
SHA-1: 137cfd4ad8f03c6bf675eedd05134480e15d803a
SHA-256: df92e6136b756716c225cc573331533d39dee3ca64e55621777c48ecc13cb3e3
Download panopoly-7.x-1.33.zipzip 274.62 KB
MD5: 22fab4e29d56e26abc35cf811ca21324
SHA-1: 21f0c64fc65f39d25427ea73e9dffe06c7d618f4
SHA-256: 4ce4257c9fceef553de826a95a144a0a08d7e8f42c90adb7816811345194f4f5

Release info

Created by: dsnopek
Created on: 14 Apr 2016 at 13:14 UTC
Last updated: 23 Feb 2017 at 03:43 UTC
Core compatibility: 7.x
Release type: Bug fixes

Release notes

This release includes a fix for a less critical security vulnerabilities in Features:

Features - Less Critical - Denial of Service (DoS) - SA-CONTRIB-2016-020

Beyond the security update, this release also includes a few small bug fixes, and one change that may require you to take some additional steps!

If you use RespondJS in order to allow your site to be responsive on IE6, IE7 or IE8 (not necessary for other browsers or newer versions of IE) then you're going to need to manually download the RespondJS library. We're no longer allowed to package it with Panopoly for licensing reasons.

See the "Installing the RespondJS library" instructions below!

Instructions on how to upgrade:

Please see the Upgrading Panopoly guide!

We support updating from Panopoly 1.15 (or newer) to this version.

Downloading the RespondJS library

If you use the respondjs module, you'll need to download the RespondJS library and put it in /sites/all/libraries/respondjs, ideally, using the same version that Panopoly has used historically (to minimize potential problems).

There are several different ways to do this (choose only one!):

1. Using 'git':

While in the sites/all/libraries directory (which you may need to create):

git clone https://github.com/scottjehl/Respond.git respondjs
cd respondjs
git checkout 86dea4ab1e93a275e2044965ab7452c3c1e2c6da

2. Downloading a .zip file from GitHub

  1. Download the .zip file from GitHub (this is the exact revision that Panopoly has historically used)
  2. Extract the files and rename the directory to "respondjs"
  3. Move to the sites/all/libraries directory (which you may need to create)

3. Adding to your distributions .make file:

Just because Drupal.org won't build Panopoly with Respondjs in our .make file, doesn't mean that you can't include it in your .make file if you have a private distribution (that isn't released on Drupal.org)! Just add these lines:

libraries[respondjs][download][type] = git
libraries[respondjs][download][url] = https://github.com/scottjehl/Respond.git
libraries[respondjs][download][revision] = 86dea4ab1e93a275e2044965ab7452c3c1e2c6da
libraries[respondjs][download][branch] = master

All changes in this release:

Changes since 7.x-1.32:

  • Getting ready for the 1.33 release
  • Update Panopoly Theme for Issue #2706279 by dsnopek: Remove the Respondjs library from Panopoly
  • Update Panopoly Core for Issue #2706259: Update to Features 2.9 for SA-CONTRIB-2016-020
  • Update Panopoly Search for Issue #2694253 by dsnopek, cboyden: Don't log searches for empty keywords
  • Update Panopoly Core for Issue #2695563 by dsnopek: Remove debug code from Panels IPE
  • Update Panopoly Magic and Test for Issue #2467073 by cboyden, dsnopek, segovia94: Preview fieldset overflows in Firefox if using a very large image
  • Start testing upgrades from the 1.32 release.
  • Restored drupal-org.make after the 1.32 release

Dependencies

The selected release is the release that will be used for automated testing. Optional projects are only used for testing.

Required

No required projects

Optional

No optional projects