There are some inconsistencies between how local tasks and local actions are handled.
For local tasks, there are 2 hooks:
hook_menu_local_tasks_alter()- this allows local tasks to be altered prior to rendering
hook_local_tasks_alter()- this allows the altering of local task plugins during discovery
For local actions, there is only one hook, and the naming convention is actually the opposite of local tasks:
hook_menu_local_actions_alter()- allows altering of local action plugins during discovery
As an immediate stop-gap, add the corresponding render alter hook, and to avoid API breakage, name it
hook_local_actions_alter(). The ideal solution would be to swap the names so
hook_menu_local_actions_alter() altered prior to rendering, but this involves an API change.
User interface changes
Possibly if renaming occurs for consistency. Otherwise no, but a Drupal WTF is introduced.