In the process of getting DrupalGap to go I discovered that the rest server was returning error code 500.
Problem was line 33 in the class ServicesRESTServerFactory does not work under php 5.2.
There were no other symptoms besides DrupalGap not connecting

Attached is my patch that resolved this problem

CommentFileSizeAuthor
services_php52_150724.patch641 byteslouis delacretaz

Comments

louis delacretaz’s picture

This may be a solution for https://www.drupal.org/node/2233575

kylebrowning’s picture

Status: Active » Closed (won't fix)

PHP 5.3 and below have reached there end of live, this will not be supported in Services.

http://php.net/eol.php

FYI, there are many many security vulnerabilities our for php 5.2, you should really move off of it.

louis delacretaz’s picture

Agreed, moving this client to the latest php is on the list :)