• Advisory ID: DRUPAL-SA-CONTRIB-2014-015
  • Project: FileField (third-party module)
  • Version: 6.x
  • Date: 2014-02-12
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Access bypass


FileField module allows users to upload files with in conjunction with the Content Construction Kit (CCK) module in Drupal 6.

The module doesn't sufficiently check permissions on revisions when determining if a user should have access to a particular file attached to that revision. A user could gain access to private files attached to revisions when they don't have access to the corresponding revision.

This vulnerability is mitigated by the fact that an attacker must have access to upload files through FileField module while creating content, and the site must be using a non-core workflow module that allows users to create unpublished revisions of content.

CVE identifier(s) issued

  • A CVE identifier will be requested, and added upon issuance, in accordance with Drupal Security Team processes.

Versions affected

  • FileField 6.x-3.x versions prior to 6.x-3.12.

Drupal core is not affected. If you do not use the contributed FileField module, there is nothing you need to do.


Install the latest version:

Also see the FileField project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Follow the Drupal Security Team on Twitter at https://twitter.com/drupalsecurity