When using the Aegir hosting system with this module, errors appear when trying to migrate, backup, or clone a site. This is because Drupal is not fully bootstrapped during these operations and the module_load_include function is not defined. There are 2 instances of this function used to include the responsive_navigation_common.inc file. For me replacing these two functions with include_once fixed the issue and allowed Aegir to work properly to manage the Drupal site.

Members fund testing for the Drupal project. Drupal Association Learn more

Comments

momendo’s picture

Ok. Please provide a patch. Thanks.

momendo’s picture

Assigned: Unassigned » momendo
adam-delaney’s picture

Status: Active » Needs review
FileSize
1.28 KB

Submitting a patch to resolve this issue using include_once.

kendouglass’s picture

The patch at #3 fixed my problem.

I was getting errors when I try to run drush commands:

Drush command terminated abnormally due to an unrecoverable error.
Error: Call to undefined function module_load_include() in /home/drupal/7/sites/all/modules/contrib/responsive_navigation/responsive_navigation.drush.inc, line 8

Thanks Adam.

blakehall’s picture

Status: Needs review » Reviewed & tested by the community

Working for me too.

momendo’s picture

Status: Reviewed & tested by the community » Closed (fixed)
mrfelton’s picture

Status: Closed (fixed) » Needs review
FileSize
433 bytes

Looks like you forgot to make the change in responsive_navigation.drush.inc. Follow u patch attached.

momendo’s picture

Thanks. I'll commit it soon.

scottrigby’s picture

Status: Needs review » Reviewed & tested by the community

Just sayin'

bjlewis2’s picture

+1

Manually made the change in #7, and no longer get the error when running "drush updb".

momendo’s picture

Status: Reviewed & tested by the community » Fixed

Committed to 7.x-1.x-dev

http://drupalcode.org/project/responsive_navigation.git/commit/40a1e29

Hopefully this fixes the drush/aegir bugs. Why does this function exist? :-/

Thanks.

v7nguyen’s picture

Version: 7.x-1.x-dev » 7.x-1.0

Hi Newbie,

I am getting into the same error code when running rush with verion 7.x-1.0, is it possible to apply the same patch? Thanks in advance :))

hass’s picture

Version: 7.x-1.0 » 7.x-1.x-dev

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.