While trying doing a config import with Drush I got confused by the mixing of the config_comparer and storage_comparer.

Let's call them the same. Latest patch choose for storage_comparer as that resembles mostly to its class.

Original code from #1890784: Refactor configuration import and sync functions

Files: 
CommentFileSizeAuthor
#7 core-config_comparer-storage_comparer-2012566-7.patch3.4 KBLuka Zitnik
PASSED: [[SimpleTest]]: [MySQL] 59,522 pass(es). View
#2 core-config_comparer-storage_comparer-2012566-2.patch3.29 KBclemens.tolboom
PASSED: [[SimpleTest]]: [MySQL] 55,322 pass(es). View
core-config_comparer-storage_comparer.patch924 bytesclemens.tolboom
PASSED: [[SimpleTest]]: [MySQL] 55,342 pass(es). View

Comments

beejeebus’s picture

Issue tags: +Configuration system

this seems legit to me.

did you look for any other occurrences of 'storage_comparer'?

clemens.tolboom’s picture

Title: Naming confusion between config_comparer and storage_comparer in config.admin.inc » Naming confusion between config_comparer and storage_comparer in config.admin.inc and other places
FileSize
3.29 KB
PASSED: [[SimpleTest]]: [MySQL] 55,322 pass(es). View

@beejeebus: good point. Scanning code there where a few more occurrences.

I now have renamed differently to storage_comparer as that resembles more this it's class.

Status: Needs review » Needs work
Issue tags: -Configuration system

The last submitted patch, core-config_comparer-storage_comparer-2012566-2.patch, failed testing.

clemens.tolboom’s picture

Status: Needs work » Needs review
Issue tags: +Configuration system
mtift’s picture

Status: Needs review » Needs work
Issue tags: +Novice, +Needs reroll

Tagging

mtift’s picture

Issue summary: View changes

Changed the preferred name from config_comparer to storage_comparer.

Luka Zitnik’s picture

Assigned: Unassigned » Luka Zitnik
Issue summary: View changes

Taking on this issue.

commit 0adc91af5c22fedfa74ad1c66cea42a3b6eb5c4e removed /core/modules/config/config.admin.inc, but there are still few $config_comparer variables left for me to rename them to $storage_comparer.

Luka Zitnik’s picture

Status: Needs work » Needs review
FileSize
3.4 KB
PASSED: [[SimpleTest]]: [MySQL] 59,522 pass(es). View

Renamed local variables $config_comparer, instances of \Drupal\Core\Config\StorageComparer, to $storage_comparer.

Status: Needs review » Needs work

The last submitted patch, 7: core-config_comparer-storage_comparer-2012566-7.patch, failed testing.

Luka Zitnik’s picture

Status: Needs work » Needs review
Luka Zitnik’s picture

Assigned: Luka Zitnik » Unassigned
lokapujya’s picture

Status: Needs review » Reviewed & tested by the community

Good change to make the variable name consistent.

alexpott’s picture

Status: Reviewed & tested by the community » Fixed

Committed 77d0c14 and pushed to 8.x. Thanks!

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.