Files: 
CommentFileSizeAuthor
#7 rename_views_method-2003528-7.patch1.02 KBmarlatt
PASSED: [[SimpleTest]]: [MySQL] 56,495 pass(es).
[ View ]
#7 interdiff.txt1.04 KBmarlatt
#4 views.module-rename-op_shorter-2003528-04.patch1.02 KBtvlooy
PASSED: [[SimpleTest]]: [MySQL] 57,292 pass(es).
[ View ]
#2 views.module-rename-op_shorter-2003528-02.patch1.02 KBtoddtomlinson
FAILED: [[SimpleTest]]: [MySQL] Repository checkout: failed to checkout from [git://git.drupal.org/project/drupal.git].
[ View ]

Comments

toddtomlinson’s picture

Assigned:Unassigned» toddtomlinson
toddtomlinson’s picture

Assigned:toddtomlinson» Unassigned
Status:Active» Needs review
StatusFileSize
new1.02 KB
FAILED: [[SimpleTest]]: [MySQL] Repository checkout: failed to checkout from [git://git.drupal.org/project/drupal.git].
[ View ]

Patch attached that renames op_shorter to addShorterThan.

Status:Needs review» Needs work

The last submitted patch, views.module-rename-op_shorter-2003528-02.patch, failed testing.

tvlooy’s picture

Status:Needs work» Needs review
StatusFileSize
new1.02 KB
PASSED: [[SimpleTest]]: [MySQL] 57,292 pass(es).
[ View ]

Add access modifiers + re-test.

heddn’s picture

Title:Rename Views method op_shorter() to addShorterThan()» Rename Views method op_shorter() to opShorterThan()

In #2003582: Rename Views method op_equal() to opEqual() it was decided to not rename a function from op_{foo} to add{foo}. So to be consistent this patch should just change the name to opShorterThan.

dawehner’s picture

Status:Needs review» Needs work

Set to needs work.

marlatt’s picture

Status:Needs work» Needs review
StatusFileSize
new1.04 KB
new1.02 KB
PASSED: [[SimpleTest]]: [MySQL] 56,495 pass(es).
[ View ]

Changed method names and changed access modifier to protected since this is called inside the class.

dawehner’s picture

Status:Needs review» Reviewed & tested by the community

Looks fine and this is the only places where this method is used.

webchick’s picture

Title:Rename Views method op_shorter() to opShorterThan()» Change notice: Rename Views method op_shorter() to opShorterThan()
Project:Drupal core» Views
Version:8.x-dev» 8.x-3.x-dev
Component:views.module» Code
Status:Reviewed & tested by the community» Active
Issue tags:+Needs change record

Committed and pushed to 8.x. Thanks!

Moving to the Views queue for the change notice.

heddn’s picture

Status:Active» Fixed

Change notice taking place in: #1856630: [Change notice] [META] Rename Views methods to core standards. Marking fixed as this was committed in #9.

Automatically closed -- issue fixed for 2 weeks with no activity.