Files: 
CommentFileSizeAuthor
#11 views-rename_op_simple-2003522-11.patch4.17 KBJeroenT
PASSED: [[SimpleTest]]: [MySQL] 55,968 pass(es). View
#8 drupal_rename_op_simple-2003522-8.patch4.15 KBnathangervais
PASSED: [[SimpleTest]]: [MySQL] 57,740 pass(es). View
#5 views-rename_op_simple-2003522-5.patch4.23 KBJeroenT
PASSED: [[SimpleTest]]: [MySQL] 56,991 pass(es). View
#2 rename_op_simple.patch2.46 KBtrevjs
FAILED: [[SimpleTest]]: [MySQL] Repository checkout: failed to checkout from [git://git.drupal.org/project/drupal.git]. View

Comments

trevjs’s picture

Assigned: Unassigned » trevjs
trevjs’s picture

Assigned: trevjs » Unassigned
Status: Active » Needs review
FileSize
2.46 KB
FAILED: [[SimpleTest]]: [MySQL] Repository checkout: failed to checkout from [git://git.drupal.org/project/drupal.git]. View
munizjor’s picture

+++ b/core/modules/views/lib/Drupal/views/Plugin/views/filter/Date.phpundefined
+++ b/core/modules/views/lib/Drupal/views/Plugin/views/filter/Date.phpundefined
@@ -178,7 +178,7 @@ function op_between($field) {

@@ -178,7 +178,7 @@ function op_between($field) {
+  function addSimpleQuery($field) {

functions needs to be public.

Status: Needs review » Needs work

The last submitted patch, rename_op_simple.patch, failed testing.

JeroenT’s picture

Status: Needs work » Needs review
FileSize
4.23 KB
PASSED: [[SimpleTest]]: [MySQL] 56,991 pass(es). View

Rename op_simple() to addSimpleQuery().

aspilicious’s picture

Status: Needs review » Reviewed & tested by the community

Done

alexpott’s picture

Status: Reviewed & tested by the community » Needs work

In #2003582: Rename Views method op_equal() to opEqual() it was decided to not rename a function from op_whatever to addWhatever. So to be consistent this patch should just change the name to opSimple (we should also drop the Query as it is not a Query - it appears to add a comparison operator)

nathangervais’s picture

Status: Needs work » Needs review
FileSize
4.15 KB
PASSED: [[SimpleTest]]: [MySQL] 57,740 pass(es). View

Rerolled patch to rename op_simple to opSimple

heddn’s picture

Title: Rename Views method op_simple() to addSimpleQuery() » Rename Views method op_simple() to opSimple()

Fixing title

aspilicious’s picture

Status: Needs review » Needs work

Talkes with dawehner about this, should be protected. Srry!

JeroenT’s picture

Status: Needs work » Needs review
FileSize
4.17 KB
PASSED: [[SimpleTest]]: [MySQL] 55,968 pass(es). View

Changed access modifier to protected as mentioned by aspilicious.

dawehner’s picture

Status: Needs review » Reviewed & tested by the community

No calls are left and code looks fine.

alexpott’s picture

Status: Reviewed & tested by the community » Fixed

Committed 35a7926 and pushed to 8.x. Thanks!

Automatically closed -- issue fixed for 2 weeks with no activity.