Files: 
CommentFileSizeAuthor
#15 views-core-rename-show-build-group-button-2003266-15.patch1.09 KBSpartyDan
PASSED: [[SimpleTest]]: [MySQL] 57,516 pass(es). View
#13 drupal-rename_show_build_group_button-2003266-13.patch1.09 KBiStryker
PASSED: [[SimpleTest]]: [MySQL] 57,242 pass(es). View
#13 interdiff.txt640 bytesiStryker
#4 2003266_changetoCamelCase.patch1.15 KBmisselbeck
PASSED: [[SimpleTest]]: [MySQL] 56,658 pass(es). View
#3 drupal-rename-show-build-group-button-2003266-2.patch1.08 KBkenianbei
PASSED: [[SimpleTest]]: [MySQL] 55,836 pass(es). View

Comments

kenianbei’s picture

Assigned: Unassigned » kenianbei
misselbeck’s picture

Assigned: kenianbei » misselbeck

Working on DrupalCon 2013 Sprint

kenianbei’s picture

Assigned: misselbeck » kenianbei
Status: Active » Needs review
FileSize
1.08 KB
PASSED: [[SimpleTest]]: [MySQL] 55,836 pass(es). View
misselbeck’s picture

Assigned: kenianbei » Unassigned
FileSize
1.15 KB
PASSED: [[SimpleTest]]: [MySQL] 56,658 pass(es). View
misselbeck’s picture

Ooops...double patch.

kenianbei’s picture

Assigned: Unassigned » kenianbei

No problem, just make sure that the issue hasn't been taken by someone before you take it on. You also should check out this page on patch naming conventions: http://drupal.org/node/707484

git diff 7.x-1.x > [project_name]-[short-description]-[issue-number]-[comment-number].patch

Status: Needs review » Needs work

The last submitted patch, 2003266_changetoCamelCase.patch, failed testing.

heddn’s picture

Failing tests. Please test and re-roll.

iStryker’s picture

Status: Needs work » Needs review
iStryker’s picture

Shouldn't the function be rename as either a public or a protected function?

heddn’s picture

If it is only used internally i.e. $this->{foo} then protected seems appropriate. Otherwise use public.

oenie’s picture

#4: 2003266_changetoCamelCase.patch queued for re-testing.

iStryker’s picture

Assigned: kenianbei » Unassigned
FileSize
640 bytes
1.09 KB
PASSED: [[SimpleTest]]: [MySQL] 57,242 pass(es). View

Following @heddn advice, making the function public.

dawehner’s picture

Status: Needs review » Needs work

Following the advice of heddn I would argue to make it protected.

I also can't see a reason why this method would be called outside of filters.

SpartyDan’s picture

Status: Needs work » Needs review
FileSize
1.09 KB
PASSED: [[SimpleTest]]: [MySQL] 57,516 pass(es). View

function changed to protected

aspilicious’s picture

Status: Needs review » Reviewed & tested by the community
alexpott’s picture

Status: Reviewed & tested by the community » Fixed

Committed 51777f2 and pushed to 8.x. Thanks!

Automatically closed -- issue fixed for 2 weeks with no activity.