Closed (fixed)
Project:
Drupal core
Version:
8.0.x-dev
Component:
block.module
Priority:
Normal
Category:
Task
Assigned:
Issue tags:
Reporter:
Created:
27 Apr 2013 at 11:02 UTC
Updated:
29 Jul 2014 at 22:14 UTC
Jump to comment: Most recent file
Comments
Comment #1
aburrows commentedComment #2
kshama_deshmukh commentedComment #3
vijaycs85Thanks to @larowlan for quick information how to handle this form. Updating IRC conversation for the self note
Comment #4
vijaycs85Initial patch...
Comment #6
aspilicious commentedYou need to move this to the block entity form controller. As it isn't executed at this moment.
Comment #7
kgoel commentedComment #8
kgoel commentedComment #10
kgoel commentedThis patch includes conversion of block_admin_edit and also, user/1 was getting access denied while accessing admin/structure/block/manage because of return false if $operation was not view in BlockAccessController.php. This patch corrects access denied issue.
There was /configure in the URL (admin/structure/block/manage/bartik.login), which was removed from the URL after talking with Tim Plunkett.
Comment #12
rgristroph commented#10: 1981144-block-admin-edit-controller-10.patch queued for re-testing.
Comment #14
tim.plunkettI believe this is blocked on #2006636: menu_contextual_links() will always return a link to the MENU_DEFAULT_LOCAL_TASK, never the parent. The offending links are being generated by contextual links.
Comment #15
tim.plunkettOkay, that went in.
Comment #17
tim.plunkett#15: block-1981144-15.patch queued for re-testing.
Comment #19
tim.plunkettLast one!
Comment #20
dawehnerSo we also have update access now?
Comment #21
kgoel commented@dawehner - can you elaborate this little more?
Comment #22
dawehnerThis text is not true anymore.
Comment #23
kgoel commentedComment #25
kgoel commented#23: block-1981144-23.patch queued for re-testing.
Comment #27
naxoc commentedHere is a reroll.
Comment #29
stella commentedPatch reroll
Comment #31
dawehnerThis should be possible to fix.
Comment #32
ParisLiakos commentedlooks good but needs a reroll
Comment #33
disasm commentedreroll!
Comment #34
dawehnerThis hunk looks unrelated and wrong.
Comment #35
disasm commentedWow, that was a mistake. Not only did I add back block_admin_add, but I failed to remove block_admin_edit callback!
See interdiff.
Comment #36
dawehnerHa!
Comment #37
yesct commentedThis issue was RTBC and passing tests on July 1, the beginning of API freeze.
Comment #38
catchCommitted/pushed to 8.x, thanks!
Comment #39
tstoecklerI don't see #6 being discussed anywhere here. I thought the same thing when I saw this in the commitlog. Why is it safe to simply remove all that code?
Comment #41
mradcliffeI've added a follow-up issue related to the default local task that isn't converted and results in a page not found.
#2052019: Fix block configuration default local task to use block_admin_edit route