This CTools module provides a set of APIs and tools to improve the developer experience.

The module doesn't sufficiently enforce node access when providing an autocomplete list of suggested node titles, allowing users with the "access content" permission to see the titles of nodes which they should not be able to view.

CVE identifier(s) issued

  • CVE-2013-1925

Versions affected

  • Chaos tool suite (ctools) 7.x-1.x versions prior to 7.x-1.3.

Drupal core is not affected. If you do not use the contributed Chaos tool suite (ctools) module, there is nothing you need to do.


Install the latest version:

  • If you use the Ctools module for Drupal 7.x, upgrade to Ctools 7.x-1.3

Also see the Chaos tool suite (ctools) project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at or via the contact form at

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.