files update versions of jquery and jquery UI

Files: 
CommentFileSizeAuthor
jquery_update.zip845.85 KBjonn59

Comments

ericduran’s picture

Status: Active » Closed (won't fix)

This doesn't apply. All these versions are already in.

JordanMagnuson’s picture

Status: Closed (won't fix) » Active

I'm a bit confused... I see jQuery 1.8.2 in the latest dev, not 1.8.3...

ericduran’s picture

Status: Active » Closed (duplicate)

Well there's an issue for updating to 1.9 which is better than just a 0.0.1 bump. Everything else is already in.

JordanMagnuson’s picture

Sure. Just FYI, there is some actual functionality in 1.8.3 that is not present in 1.8.2... for instance this quickfilter plugin actually requires that 0.0.1: http://labs.syropia.net/jQuery-Quick-Filter/demo.html

JordanMagnuson’s picture

Status: Closed (duplicate) » Active

Just thinking about this a bit more... considering that there is some added functionality in 1.8.3, doesn't it makes sense for this module's "1.8" version of jQuery to be the last released 1.8 version (even after 1.9 is included)? Not trying to quibble about the 0.0.1, but it does seem like a best practice to include the latest version of the given major release...

Feel free to close again if you disagree...

JordanMagnuson’s picture

I'd be happy to provide a patch, if it makes any difference...

ericduran’s picture

So it's not feasible for this project to update jquery every single 0.0.1 release.

So instead of wasting bandwidth I would rather just update to 1.9 which if you want the features in 18.3 you can just use 1.9 instead.

Does this make sense?

JordanMagnuson’s picture

I can wait for 1.9. But I don't quite understand why 0.0.1 patches cannot be applied, if someone is willing to create and submit them?

One issue about waiting for a new major release, is that it's possible for some backwards compatibility to be broken... i.e. it's possible that 1.8.3 would work for my needs, but 1.9 would break something... See, for instance: http://stackoverflow.com/questions/14595108/jquery-1-9-backward-compatib...

Obviously I can role my own little custom module, where I grab the latest version of 1.8, but it seems like that would be a shame, when the purported purpose of this module is to provide the latest major versions of jQuery... I don't quite understand where the waste of bandwidth comes in...?

klonos’s picture

Title: Update jQuery 1.7.2, 1.8.3 and jQuery UI 1.8.24 » Offer latest jQuery 1.7.x as an option (currently 1.7.2).
Version: 7.x-2.3-alpha1 » 7.x-2.x-dev
klonos’s picture

Title: Offer latest jQuery 1.7.x as an option (currently 1.7.2). » Keep jQuery 1.7.x updated to the latest version available (currently shipping 1.7.1 - update to 1.7.2).

...

klonos’s picture

Component: Miscellaneous » jQuery 1.7.x
markcarver’s picture

Version: 7.x-2.x-dev » 7.x-3.x-dev
Issue summary: View changes
Parent issue: » #2852350: [jquery_update] 7.x-3.0 stable release

Not sure if this was done or not... needs to be checked.