Installed views module (replacing all previous files in the views module folder)
Invoked administer -> modules
Pressed update.php -- pressed select version; views module was not listed.
Table 'vaware_drupal.view_view' is not being created. Here are the steps I took:
Checked the modules views and views_ui and pressed Submit.
Got the message "The configuration options have been saved." and the following message:
"user warning: Table 'vaware_drupal.view_view' doesn't exist query: SELECT * FROM view_view WHERE page = 1 in /home/vaware/public_html/includes/database.mysql.inc on line 120."
Invoked administer -> access control and set permissions.
Returned to administer -> modules and pressed update.php again. This time the views module was listed but indicated "no updates available", along with numbers 1 thru 7 (which I don't know how to interpret).
PS: I did not see the message "Installing Views"
I am at a loss as to how to proceed.
Comments
Comment #1
merlinofchaos commentedUgh, I hate when this happens.
Run the following query:
DELETE FROM system WHERE name LIKE 'views%';
Then go to your modules page and enable views and views_ui.
Comment #2
betsyj commentedThanks. I'll try that tomorrow.
Comment #3
zach harkey commentedWow, merlinofchaos that information is priceless. Thank you.
Comment #4
merlinofchaos commentedI assume that worked.
Comment #5
(not verified) commentedComment #6
seanrI'm getting this on every on every single site on which I activate this module. The module does work fine, however, never had to reinstall or anything like you suggest. Something's running that query before the table is created, I just can't figure out which one. A quick check of the DB show's the table listed so it was definitely created. Color me perplexed.
Comment #7
merlinofchaos commentedI've never seen anything like this; can you come up with a minimal configuration that replicates this? I realize it may be difficult, since it's a lengthy process to test, but I'm at a loss to recreate it at all without having some idea what modules might be causing it.
Comment #8
Leeteq commentedI see this too, on both 4.7.2 and 4.7.3 sites, even when I have completely removed the previous views module version, both from the file system and the views tables. After I recreate the tables manually I can disable and enable the module without errors, but no admin menu appears, and the url does not work. I will post an update here when I have tested by removing modules to see if that helps. PS. one of the sites is a brand new 4.7.3 site, not an upgraded site. But that one has many contributed modules, so I have to do some tests for module incompabilities.
Comment #9
Leeteq commentedBTW: the previous comment is from trying to use yesterday's updated Views version.
Comment #10
Leeteq commentedok, I found out when and why this happens:
On installation, I only enabled the views module, not the views_ui module at the same time, the latter is the one creating the view_view table... (would enable as little as possible first, to avoid... errors - I thought)
I think that the most important thing to do first now is that the dependency between these two modules should be stated in the module description text that appears on the modules administration page. That is the safest to ensure that they will both be enabled at the same time.
Then the README file should be updated. In the INSTALL section, it currently only says:
"Please note that this is now TWO modules -- views.module and views_ui.module".
It should instead say something like:
"Please note that this is now TWO modules -- views.module and views_ui.module
These modules must BOTH be enabled. This is particularly important the first time you enable the views module."
Further: perhaps include a message about the dependency in the error message itself, or simply do some error handling that enabled the views_ui module if it isnt enabled?
BTW, after I solved this, the current/latest views module version as of today seems to be working fine.
Setting this issues as a "critical task", not "bug".
Comment #11
merlinofchaos commentedThis is completely incorrect. There isn't even a views_ui.install; it is DEFINITELY not responsible for creating the views tables.
views.install contains views_install() hook -- Drupal *should* be executing this when you install views for the first time. And it should be unrelated as to whether or not you enable views_ui or not.
Pretty much anything that followed based on this conclusion is incorrect.
Comment #12
pbros commentedI just brought up a fresh installation of 4.7.3. I was getting the exact same error. The advice from "merlinofchaos" was right on the money.
Part of my problem was I only copied over the "views.module" file. I didn't copy over the "views_ui.module" until I took merlinofchaos' advice.
Comment #13
Leeteq commentedok, so there is no install for the ui module, and it is not creating the table, but what happened in practise was that the tables in fact were only created when I enabled those modules together (at the same time) the _first_ time I installed views. That is what prevented that error.
Sorry for the bad explanation/conclusion, but at least the point is that I had to enabled them both the first time to avoid the error and get the table created.
Comment #14
merlinofchaos commentedYou don't have to enable views_ui to avoid this error. It has nothing to do with it, unless there's a bug in Drupal regarding views and views_ui being similarly named causing all this.
Comment #15
(not verified) commented