Hi!

Very exciting that you've finally posted beta of the new version. However, when upgrading superfish by overwriting the old version (with some patches added), then running the update script... The entire website is broken with a fatal error.

I can not get to the /admin/modules or anywhere...

That's not good...

Comments

dhatman’s picture

solved by removing superfish module folder, enabling Libraries module in /admin/modules,
restored superfish module folder, disabled superfish module, uninstalled superfish module, installed superfish module.

mehrpadin’s picture

Hey there,

You should have enabled the Libraries API before uploading the new Superfish module (don't forget the Superfish library).

dhatman’s picture

I also get a lot of notices and warnings, and I'm not sure if it's related to not doing a fresh install of the updated module.

I tried updating it on another site and installed the libraries module before overwriting the old superfish 1.8alpha. I then run the update script and it updated the hook something.

I now get notices like this:
Notice: unserialize(): Error at offset 2 of 8 bytes in variable_initialize() (line 749 of D:\Development\www\bellarosa\includes\bootstrap.inc).
Notice: unserialize(): Error at offset 2 of 8 bytes in variable_initialize() (line 749 of D:\Development\www\bellarosa\includes\bootstrap.inc).
Notice: unserialize(): Error at offset 10 of 11 bytes in variable_initialize() (line 749 of D:\Development\www\bellarosa\includes\bootstrap.inc).

I got similar notices on the other site.

I tried uninstalling the superfish module and reinstalled and I got the following notices:

Notice: Undefined variable: blocks i superfish_block_info() (rad 50 av D:\Development\www\bellarosa\modules\superfish\superfish.module).
Warning: Invalid argument supplied for foreach() i _block_rehash() (rad 386 av D:\Development\www\bellarosa\modules\block\block.module).
Notice: Undefined variable: blocks i superfish_block_info() (rad 50 av D:\Development\www\bellarosa\modules\superfish\superfish.module).
Warning: Invalid argument supplied for foreach() i _block_rehash() (rad 386 av D:\Development\www\bellarosa\modules\block\block.module).
Notice: Undefined variable: blocks i superfish_block_info() (rad 50 av D:\Development\www\bellarosa\modules\superfish\superfish.module).
Warning: Invalid argument supplied for foreach() i _block_rehash() (rad 386 av D:\Development\www\bellarosa\modules\block\block.module).

It seems to be working fine though.. it's just that the update process from older version is not entirely smooth.

ssg13565’s picture

> You should have enabled the Libraries API before uploading the new Superfish module (don't forget the Superfish library).

If the order is important (and I verified that it is), then the documentation for V1.9 ought to specify the items in the order that they need to be installed. When I looked, the order was not listed as the one you describe.

daniorama’s picture

The main problem about updating is not having libraries installed before. It causes a nasty bug in drush making it unusable but doing as dhatman says works well, the only thing is that you cannot use drush to do it and you have to do it manually. There should be a way to prevent updating or at least not loading those functions if libraries is not present.

badbuta’s picture

"solved by removing superfish module folder, enabling Libraries module in /admin/modules" <-- I cannot find the "Libraries" Module in my admin/module page. I am using latest D7.0.

I have checked there is a project called "Libraries" -- http://drupal.org/project/library. However, it only supports D6.

I have decided to restore the Superfish and wait for new version with fix.

badbuta’s picture

Thanks for Mehrpadin msg that telling me the URL of Libraries API module (Not Library Module ;-) ). Superfish is upgraded after following the installation guide.

mehrpadin’s picture

The libraries_get_path error is fixed as of 7.x-1.9-beta2 (update: now called as v1.8); and I'm not getting those notifications, any clues?

dhatman’s picture

They do not occur for me with 1.9-beta2 and I they only occured a few times with beta1. I think it had to do with me using Superfish blocks that were not properly uninstalled when uninstalling the module, as I had overwritten the old version with new version. But no big issue with it as far as I can tell.

mishmobile’s picture

Version: 7.x-1.9-beta1 » 7.x-1.8

@dhatman, Mehrpadin,

Thanks for explaining that the Libraries module needed to be fully installed before installing Superfish. I was able to rectify this error for myself using Superfish 7.x-1.8 by following dhatman's procedure.

atmosfearic1’s picture

I should've taken notes or written this at the time, but here's what I remembered.

I tried #1's solution to no avail
It would say that superfish was still installed when I had taken it out of the module folder
So then I decided to disable Libraries and noticed that it was greyed out bc View Slidehow:Cycle was using it
I also noticed that 3 of the Views were greyed out
So i turned off all the Views
then I turned off the libraries module
then I turned off all the Chaos tools( It should just be the ones that use Views, but I wanted to be sure)
then I turned off 3 previously greyed out Views
I put the Superfish folder back into modules
then I turned on Libraries
then I turned on Superfish
and it worked.
when you enable the rest you have to turn them back on the same way. U cannot just turn them all on
or you get this:
DatabaseSchemaObjectExistsException: Table ctools_custom_content already exists. in DatabaseSchema->createTable() (line 652 of /Users/jtv/Desktop/ihealth2a/includes/database/schema.inc).

I hope this helps!

atmosfearic1’s picture

Even after I successfully enabled the Superfish in the modules, I kept getting an error about installing the superfish library. It took me a bit but I figured it out.

you have to check the configuration of Superfish bc I had to create a folder "superfish" & placed all the scripts in there to make it realize that the superfish libraries were installed!
sites/all/libraries/superfish/

This is what is listed when you click on configure to the right of the enabled Superfish module:
sites/all/libraries/superfish/jquery.hoverIntent.minified.js
sites/all/libraries/superfish/jquery.bgiframe.min.js
sites/all/libraries/superfish/superfish.js
sites/all/libraries/superfish/supersubs.js
sites/all/libraries/superfish/supposition.js
sites/all/libraries/superfish/sftouchscreen.js

So because of no "superfish" folder, the error about installing the superfish library kept coming on even after I had superfish running in the modules!

porg’s picture

1) a) This is really a KILLER bug. Usually others module crashes are resolved with removing the plugin folder or deacivating it on the database table system. But this one really left the system in an unrecoverable state. Luckily I had a backup.
b) Meanwhile (today 2011-09-23) the project site has an installation instruction, with a clear order. Please add the hint "Follow the installation order crucially, otherwise you can suffer bug (link to here)".

2) I have the most recent Drupal from the 6 series, followed the installation instruction for v1.8 and nevertheless again had this fatal unrecoverable errors, involving bootstrap.inc (as described by others above). I already had Superfish installed once. I think this left some legacy data in the database, which may cause the troubles. What must I manually remove in the database, to finally get it going?

xbrianx’s picture

I followed this exactly after having it fail on me the first time. I made a fresh install of drupal and tried and the same error:

Please download the Superfish library from http://drupal.org/project/superfish. (Currently using Superfish library Not installed)

  • Step one install the superfish libraries in sites/all/libraries
  • step two install libraries module and enabled it
  • step three install superfish module try to enable and get the error. So fustrating!!

What do you need to do to get this sucker to work?

Thanks!

xbrianx’s picture

Fixed the error. the directions say to put the superfish libraries in sites/all/libraries/ however it really should be in sites/all/libraries/superfish/

dberkowitz’s picture

I'm having similar problems. I've deleted the superfish module folder, I've installed the libraries module and enabled it, installed the superfish libraries in a sites/all/libraries/superfish folder, and then I tried reinstalling the superfish module itself only to get the following error:

Notice: Undefined index: log in update_authorize_install_batch_finished() (line 236 of /Users/davidberkowitz/Sites/acquia-drupal/modules/update/update.authorize.inc).
Warning: Invalid argument supplied for foreach() in update_authorize_install_batch_finished() (line 236 of /Users/davidberkowitz/Sites/acquia-drupal/modules/update/update.authorize.inc).
Notice: Undefined index: log in update_authorize_install_batch_finished() (line 277 of /Users/davidberkowitz/Sites/acquia-drupal/modules/update/update.authorize.inc).
Notice: Undefined index: tasks in update_authorize_install_batch_finished() (line 278 of /Users/davidberkowitz/Sites/acquia-drupal/modules/update/update.authorize.inc).
Installation failed! See the log below for more information.

Next steps

Administration pages
Front page

I of course am getting the "Please download the Superfish library from http://drupal.org/project/superfish. (Currently using Superfish library Not installed)"

Suggestions?

David

tryitonce’s picture

.... having worked my way through getting Superfish going on localhost with the usual frustration described by others I found that in my libraries directory the Superfish sub-directory had a
capital "S" .../Superfish/ changing it to lower-case = .../superfish/ helped - it seems -
but it was part of the various steps of re-activating the modules step by step.
So, I cannot be certain - but someone might be in the position to try it before going back through the de- and in-stalling procedures.
....

jagabriel’s picture

Thanks tryitonce
That was exactly what was wrong with my installation

greetings

mehrpadin’s picture

Category: bug » support
Priority: Critical » Normal
mehrpadin’s picture

Status: Active » Closed (works as designed)