Hello,

The direct unsubscribe links (all of them) that are found in the emails (namely for digest) all lead to a Page Not Found.
Example of error:

The requested page "/s/del/node/tid/1/-1/2/51e054a0baef3da1557ab622549a62fd" could not be found.

Could this be because I am using pathauto?
I am still able to go to the individual content and unsubscribe, as well as go to /user and unsubscribe there.

Thank you for your time.

CommentFileSizeAuthor
#15 broken_unsubscribe-1744576-15.patch480 bytesfuzzy76

Comments

salvis’s picture

Status: Active » Fixed

Thank you for your report.

I've just pushed a fix to the -dev version (give it up to 12h to be repackaged).

Please try it out and let us know how it goes!

rawrzors’s picture

Works great

Thanks!

salvis’s picture

Great, thanks!

rawrzors’s picture

Status: Fixed » Active

A few of my users just got an email that looked like this:

| LINK: http:///forum/news-influenza-h3n2v-variant-virus-updates
| ---------------------------------------------------
| Direct unsubscribe link (category):
| http:///s/del/node/tid/1/-1/2/51e054a0baef3da1557ab622549a62fd
=====================================================
| This is an automated message. Please do NOT reply to the sender address!
| To manage your subscriptions go to
| http:///user/2/subscriptions

I did not remove my website address. It came emailed like that.

However, if I add in my website address after http://, the unsubscribe works.

salvis’s picture

@rawrzors:

This is something completely different. It's a variant of #226335: Incorrect URL in Subscription Email, i.e. an issue of Drupal core and your particular installation.

salvis’s picture

Status: Active » Fixed
nadfserver’s picture

Hello,

The requested page "/s/del/node/tid/1/-1/2/51e054a0baef3da1557ab622549a62fd" could not be found.

But I am using Version 6.x-1.5 for Drupal 6.

As it is fixed in 7.x maybe you can tell me how to fix that in 6.x-1.5 version too?

It would be really nice to help me :)

Thanks a lot!

Kind regards

salvis’s picture

Is the link bad (missing host name) or is the server not recognizing the path?

nadfserver’s picture

The host is added and just cut off in my post. It's a 404-http error. I can not unsubscribe via Link which is included in the send-email. On page itself, i can manage the subscribtions without issue. Just the direct link from the email is not working :(

salvis’s picture

Version: 7.x-1.x-dev » 6.x-1.5

This is a regression in D6 caused by #1585516: Users can not update their own future Send interval.

I've pushed the fix to the -dev version (give it up to 12h to be repackaged).

nadfserver’s picture

Hi,

I just substituted the file "subscriptions.module" from the DEV-Version with the current stable version and it works fine for me. I did not noticed any problem with that "hack" ;) I am looking forward to see that included in a next stable version :)

Well done and thanks a lot!!!!

Regards

salvis’s picture

Great, thanks for letting us know.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

fuzzy76’s picture

Issue summary: View changes
fuzzy76’s picture

StatusFileSize
new480 bytes

Did not apply to latest stable, so here's a reroll for those of us that won't run dev.