Closed (fixed)
Project:
reCAPTCHA
Version:
6.x-1.1
Component:
reCAPTCHA Captcha
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
12 Feb 2009 at 23:57 UTC
Updated:
14 Apr 2011 at 11:21 UTC
I keep getting the error "For security reasons, you must pass the remote ip to reCAPTCHA" when I try to submit my contact form as an anonymous user. Authenticated users work fine. However, authenticated users don't need to use recaptcha, so there's probably a configuration issue with Drupal and my host somewhere.
I'm on a slicehost Ubuntu 8.10 instance, and Drupal 6.9. Thanks for any help.
Comments
Comment #1
cybertoast commentedFigured it out. Turns out I did not have my nginx.conf file send the remote_address to fastcgi. Oops! For anyone who runs into a similar problem, make sure that your nginx config contains the following:
Obviously only remote_addr is necessary to fix the problem reported.
Comment #2
the_g_bomb commented