The problem is that the new release if recaptha needs PHP version 5.5 and my hosting system has only 5.3.29. The fact that I only have version 5.3.29 should not pose a problem because the minimum PHP requirements of Drupal core is 5.3.
Should the reauirements of a module not always equal or less than the requirements of the core?
The problem is now that I keep getting messages that there is a newer version of recaptcha and I have to update but I can't.
Anyone has a solution for this issue (I know, i can ask my provider to update the PHP version :-)

Comments

EricVL created an issue. See original summary.

hass’s picture

Status: Active » Fixed

The recaptcha library has a minium requirement of PHP 5.5.

There are currently issues in queue for review to discontinue PHP 5.3 support in D7 Core. PHP 5.3 is long time not supported. You should change your hoster or upgrade. PHP 5.6 is also no longer supported and PHP 7.0 is no longer supported in 1 year or so.

Please protect your unsupported server or someone will break into it.

ericvl’s picture

Thank you for your quick response, hass.
I know that PHP 5.3 is not supported anymore but because the core was still supporting it, I thought that all modules were required to support it too.
Have a nice day.

hass’s picture

Maybe a good idea, but no - every module can define it‘s compatibility. I tried it for a really long time. Have not expected someone really run php53 in 2019.

ericvl’s picture

OK, thanks.
With the idea of "never change a winning team" I would not ask my provider to change the PHP version every time a new version has been released but there come a time if some piece of software needs a new feature that is in a newer PHP-release then the moment has come to upgrade.
Thank you for your time Alex and Tjüss

quchidru’s picture

HI I'm having the same problem - running d7.63 with php 5.4.x and 5.3.x - there is no way to upgrade php now
Risk to break too many installations ( not all drupal)

hass’s picture

The risk is very small. The risk that someone breaks into your server is 10000 times higher.

quchidru’s picture

I wish but have no choice at least for a while, not to mention a few very large D6 sites ! ;)
Is there any hack, edits one can do not to require 5.5+ ?
PS - I have some servers with php 7.2 and i did try to move a site there - way too many errors - mostly on views

j_s’s picture

I have the same issue. Red Hat Enterprise Linux 7 runs PHP 5.4 and will always run PHP 5.4. When RHEL 8 comes out, that's expected to use PHP 7. But in the mean time, since Red Hat's distribution has the expectation that enterprise-level software does not fundamentally change within major versions, Red Hat back ports security patches from the latest version of PHP. That means there's no security implications for RHEL users (as long as they keep patching).

Please update the module, or provide some workaround, so that people can continue using PHP version < 5.5. Or perhaps branch it to 7.x-3.x.

At least so far, it seems like recaptcha still functions even so it can't be enabled or disabled in the modules area. If it does stop functioning, we'll have to switch to something else.

hass’s picture

You can manually remove php = 5.5 line from .info file, but this is not supported. The recaptcha library itself requires php 5.5 per recaptcha-php\composer.json.

Aside of this you do NOT need to upgrade. You can also stay at the old version. It still works and does not automatically collapse only because a newer version came out.

wavesailor’s picture

This is broken a lot of my sites and just allowed spammers to spam the sites.
Drupal 7 requirements have always been 5.3 but most sites run 5.4 by default.

Now I get this This module requires PHP version 5.5.* and is incompatible with PHP version 5.4.45.

Like others said above, the default at most hosting providers is 5.4 and cannot be changed.

Please could you reconsider changing it to 5.4

j_s’s picture

Why was this module updated to this PHP version now anyways? The Recaptcha PHP library updated their requirement back in 2017:
https://github.com/google/recaptcha/commit/4e9e7bbb47d77277f47e5f91e8ae0...

What are the dependencies they changed it for? Was it for phpunit? On sites where I already had Drupal recaptcha enabled, it still works normally despite this requirement from Recaptcha PHP library.

hass’s picture

Guys - PHP 5.6 and ealier versions are no longer supported. The versions you want support for are not supported for years. That is why I started following the library requirements. Drupal 8.7 will not support PHP 5.6, too. I never expected someone is sooo crazy to run software that is 5 or more years not supported. Simply upgrade your extreme outdated servers, please. Your sites will run fine under php7 or php71. For the rest you have been told about a workaround above.

Do not tell me an upgrade of PHP is not possible, please. I also upgraded my Debian servers to secure versions.

And that the hoster does not allow newer versions should really really really make you re-thinking to choose a different/quality hoster. But aside of this I do not trust that they are not providing a newer PHP versions. Maybe you should ask them first.

j_s’s picture

hass, as I've already explained, Red Hat Enterprise Linux runs PHP 5 for enterprise systems and will not update to PHP 7 for the duration of their existing release. The next version of RHEL is not out of beta yet, which means it is impossible to update without using unsupported side loading of extended Red Hat tools.

That, coupled with the fact that Drupal itself officially supports PHP 5.3 for the life of Drupal 7 means PHP 5 should continue to be supported.

hass’s picture

Is PHP 7 (php7) available in RHEL 6 or RHEL 7 via RHSCL? or remove Redhat from your disk and install Debian.

This module has a minium requirement of PHP 5.5. Everything else you need to discuss with the Google maintainers of the library.

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.

Eduardo Alvarez’s picture

Same issue here, we are running a mid-large Drupal 7 multisite infrastructure since 7 years or so for a large scientific organization. The infrastructure is based on the RHEL 6, so default 5.3.3 version (with security patches backported by RedHat)

Certainly can be technically possible by switching to a newer version of PHP using the RedHat Software Collections, but at least in our case this will be a major change in our infrastructure and worthless for an infrastructure that will die in less than 2 years.

For the moment we will stay with the previous relesase version of the module, but I guess we are lost in case of future security releases.

brad.bulger’s picture

sorry, user error and no delete button here