I have installed the Panopoly distribution on my localhost running on xampp for windows. I have gone through the installation process successfully and when asked to visit my site I get this error.

PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away: SELECT filename FROM {registry} WHERE name = :name AND type = :type; Array ( [:name] => linkit_profiles_ui [:type] => interface ) in _registry_check_code() (line 3091 of C:\xampp\htdocs\panopoly\includes\bootstrap.inc).

I have looked into the error and it appears to be an issue with MySQL my.ini settings. I have changed
innodb_lock_wait_timeout =50
to
innodb_lock_wait_timeout = 600

and

max_allowed_packet = 64M
to
max_allowed_packet = 156M

restarted xampp serveral times and I still get the error. Is there something I have missed?

Comments

timtk’s picture

Assigned: Unassigned » timtk
Status: Active » Closed (fixed)

Looks like it solved itself. Restarted my machine twice and now its working. Might have been an issue with the xampp restart.

timtk’s picture

Assigned: timtk » Unassigned
Status: Closed (fixed) » Active

Sorry i take that back its stopped working again, withthe same error. Seems to be on and off. Not sure what the cause is.

lsolesen’s picture

Status: Active » Closed (won't fix)

This is a server setting issue. Try upping your values futher.

old_dog’s picture

Gettng similar errors after a seemingly clean installation when invited to "visit my site" (using bitnami Lamp stack on kubuntu 13.04)

PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away: SELECT * FROM {menu_custom}; Array ( ) in menu_load_all() (line 237 of /home/gerry/lampstack-5.3.27-0/apps/drupal/htdocs/modules/menu/menu.module).

Uncaught exception thrown in shutdown function.

PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away: DELETE FROM {semaphore} WHERE (value = :db_condition_placeholder_0) ; Array ( [:db_condition_placeholder_0] => 4907344815293ee9f859432.22096574 ) in lock_release_all() (line 269 of /home/gerry/lampstack-5.3.27-0/apps/drupal/htdocs/includes/lock.inc).

Uncaught exception thrown in session handler.

PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away in _drupal_session_write() (line 209 of /home/gerry/lampstack-5.3.27-0/apps/drupal/htdocs/includes/session.inc).

The messages appear in the order shown top to bottom, with the top one in a red box.
If I refresh the page, the red box message changes to

PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away: SELECT filename FROM {registry} WHERE name = :name AND type = :type; Array ( [:name] => linkit_profiles_ui [:type] => interface ) in _registry_check_code() (line 3091 of /home/gerry/lampstack-5.3.27-0/apps/drupal/htdocs/includes/bootstrap.inc).

old_dog’s picture

Issue summary: View changes
Priority: Normal » Major
Status: Closed (won't fix) » Active
cliffo4’s picture

Have had similar situations, clearing cookies for the server address and / or sessions in Apache actually got the site up - then similar errors to those about when trying to use the login form to login as admin.

I have to assume that immediately after install it attempts to have you logged in and fails, which is why clearing cookies gets a step further untill you feel the need to login.

Have tried different versions of PHP (5.4.15) and MYSQL (5.6.11) on a Windows uAMP (2.2.1) base and WAMP PHP (5.4.3) and MYSQL (5.5.24).

Tried with and without the News App.

So I gave up after that. :(

cliffo4’s picture

Another point of note, installing Drupal Core 7.23 using the same uAMP install, does all work fine, installs in under 2 minutes and straight in as admin on visiting the site.

Worth noting regarding timing above, that that there is less than a 10 second delay on entering the Login screen to it failing on the Panolopy Disto - so I cant see its exceeding any timers?

I hope the extra info is of use.

cliffo4’s picture

Found a fix drupal.org/node/2065389 PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone

increase mysql setting from 1meg to 2meg:
max_allowed_packet = 2M

lsolesen’s picture

Priority: Major » Normal
Status: Active » Closed (won't fix)

Hope this solves your problems.

Andrea C’s picture

Same problem

increase mysql setting from 1meg to 2meg:
max_allowed_packet = 2M

worked for me

nellngun’s picture

Any suggestions, how to solve it on shared server?