Problem/Motivation

When on 3.3.5 (fresh install, no prior versions), if we do composer require 'drupal/group:3.3.x-dev@dev' or composer require 'drupal/group:^4.0@alpha' and after we run updb drush updb, the following error is returned by drush:

 [error]  The installed version of the /Group/ module is too old to update. Update to a  
version prior to 2.0.0 first (missing updates:  
group_post_update_group_type_group_content_type_dependencies,  
group_post_update_group_content_type_dependencies,  
group_post_update_grant_access_overview_permission,  
group_post_update_view_cache_contexts,  
group_post_update_make_group_revisionable).

It looks like the group.post_update.php file is empty in any 3.x version; however, in 2.x / 3.3.x-dev and 4.0.x branches, the file contains

function group_removed_post_updates(): array {...}

and that causes the error when doing 3.3.5 -> 3.3.x-dev/4.0@alpha

Steps to reproduce

fresh install of 3.3.5
then composer update to either dev-3.3.x or 4.0
after, run drush updb

Issue fork group-3620824

Command icon Show commands

Start within a Git clone of the project using the version control instructions.

Or, if you do not have SSH keys set up on git.drupalcode.org:

Comments

gorkagr created an issue. See original summary.

gorkagr’s picture

my bad, wrong comment

hai nguyen made their first commit to this issue’s fork.

hai nguyen’s picture

Status: Active » Needs review