When upgrading from 3.3.5 to 4.0.0-alpha1 I get this error:
$ composer require 'drupal/group:^4.0@alpha'
./composer.json has been updated
Running composer update drupal/group
Gathering patches for root package.
Removing package drupal/conditional_fields so that it can be re-installed and re-patched.
- Removing drupal/conditional_fields (4.0.0-alpha6)
Removing package drupal/core so that it can be re-installed and re-patched.
- Removing drupal/core (11.3.8)
Removing package drupal/rules so that it can be re-installed and re-patched.
- Removing drupal/rules (4.0.1)
Deleting /var/www/html/modules/contrib/conditional_fields - deleted
Deleting /var/www/html/modules/contrib/rules - deleted
Deleting /var/www/html/core - deleted
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- Root composer.json requires drupal/group ^4.0@alpha, found drupal/group[4.0.0-alpha1] but these were not loaded, likely because it conflicts with another require.
Problem 2
- drupal/subgroup is locked to version 3.1.0 and an update of this package was not requested.
- drupal/subgroup 3.1.0 requires drupal/group ^3.0 -> found drupal/group[3.0.0-beta1, ..., 3.3.5] but it conflicts with your root composer.json require (^4.0@alpha).
Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
Then I try to remove the subgroup module with composer but I get this error:
$ composer remove drupal/subgroup
That's works properly, but when I try to execute update.php I get this error:
Missing or invalid module
The following module is marked as installed in the core.extension configuration, but it is missing:
subgroup
So I have to reinstall again.
How can I upgrade to 4.0.0-alpha1?
Thanks in advance!
Comments
Comment #2
joinso commentedSolved.
Just missing to first unistall from admin page.
Sorry!