This project is not covered by Drupal’s security advisory policy.

Let's face it, upgrading old modules to the new form API in Drupal 4.7 can be quite a challenge. Form Updater can help developers with the upgrade by automatically searching through old Drupal code to find calls to old form functions (such as form_textfield, form_radios, etc). It will then reformat these functions as arrays for use with the new Drupal 4.7 form API. It's far from a complete solution, but it provides a big kick-start for the upgrade.

This module uses the new form api itself, so it requires the CVS (4.7) version of Drupal in order to run.

This module works just fine, however is no longer maintained. Please see the Coder module for a continuation of this type of code checking in Drupal 5 and forward.

Project Information

  • Maintenance status: Unknown
  • Development status: Unknown
  • Module categories: Developer
  • Downloads: 2,854
  • Last modified: 2 December 2014
  • shield alertThis project is not covered by the security advisory policy.
    Use at your own risk! It may have publicly disclosed vulnerabilities.

Downloads