Closed (won't fix)
Project:
Drush
Version:
7.x-4.5
Component:
PM (dl, en, up ...)
Priority:
Normal
Category:
Support request
Assigned:
Unassigned
Reporter:
Created:
4 Jan 2012 at 01:35 UTC
Updated:
7 Mar 2013 at 03:07 UTC
I have a site that is using svn as version control (the whole site is in version control).
If I run something like drush up views everything works as expected and then I just commit the changes to svn.
If I run drush up drupal it fails and I have to restore everything manually from a backup I created before running the command.
When I run drush up -vd drupal drupal downloads and renames successfully and then at the end i get
Project drupal was updated successfully. Installed version is now 7.10.
Rolling back update of Drupal core code ... [243.58 sec, 80.52 MB] [notice]
Verifying signature for svn version control engine. [243.58 sec, 80.54 MB] [debug]
Executing: svn info 'drupal-7.10'
drupal-7.10: (Not a versioned resource)
svn: A problem occurred; see other errors for details
Verifying signature for bzr version control engine. [243.67 sec, 80.2 MB] [debug]
Executing: bzr root 'drupal-7.10'
sh: bzr: not found
Undefined index: backup_target backup.inc:46 [243.7 sec, 80.19 MB] [notice]
Calling is_readable(Object) [243.7 sec, 80.19 MB] [debug]
Source directory is not readable or does not exist. [243.71 sec, 80.19 MB] [error]
Could not restore backup and rollback from failed upgrade. You will need to resolve manually. [243.71 sec, 80.19 MB] [error]
Changes made in drush_pm_updatecode have been rolled back. [243.71 sec, 80.19 MB] [rollback]
Command dispatch complete [243.73 sec, 80.12 MB] [notice]
Timer Cum (sec) Count Avg (msec)
page 243.578 1 243578.18
Peak memory usage was 90.55 MB [243.74 sec, 80.11 MB] [memory]
Does any one have any ideas what is going?
Comments
Comment #1
MD3 commentedJust a thought, do you know what your PHP memory limit is?
Comment #2
rooby commentedI'm pretty sure it is 128 but I'll have to check tomorrow.
The cli limit might be different or something. I don't have any problems with drush core updates for any other sites on that server.
This one has a decent size install profile but it isn't huge.
The others don't have custom install profiles at all which is why I've been thinking that has something to do with it.
I would expect to see a memory limit error if it were that.
Comment #3
rooby commentedMy apache php memory limit is 512, cli memory limit is 256, max execution time for both is 120 seconds.
It is a dedicated local dev server so there shouldn't be any resource issues.
Comment #4
greg.1.anderson commentedClosing support request due to lack of activity. Sorry no one was able to help you with your issue. Please re-open if you are still having trouble, or consider posting a question on Drupal Stack Exchange. If you have solved your problem, it would be helpful it you posted the resolution here to help others who may have the same problem in the future.
Comment #5
rooby commentedTo be honest I can't remember what site I was even seeing this on.
If I come across it again I will re-open.