When changing the File system path on: admin/settings/file-system with the "private" method, the user picture path in the users table stays the same, rendering all user pictures to fail to load. Instead the full file system path is appended, i.ex. gets to: /system/files/var/www/my_site/pictures/picture-1.png, instead of: /system/files/pictures/picture-5.png

Changing all the real file system pathes in the users table to the new path solves this issue.

Expected behavior would be, that when changing the file system path, the picture field in the users table gets updated to, or at least a note would clearly state what has to be done after modifying the File system path.

Comments

Status: Active » Closed (outdated)

Automatically closed because Drupal 6 is no longer supported. If the issue verifiably applies to later versions, please reopen with details and update the version.