Since this morning, it is completely impossible to edit our drupal website.

When trying to edit a page, everything seems to work fine, until we try to save. At that moment, no error is reported, and the edit overlay is displayed again.

Similarly, when trying to add a user, we can fill the form, but upon adding, it just empties the form and does nothing.

In case of a corrupt database, I would expect there to be errors at least.

What could be causing this?

Browsing the site and logging in works fine.

Thanks,
Hans

Comments

bfroehle’s picture

Category: bug » support

@Hans, I have two ideas:
1) Disable the overlay and try again.
2) Look in your error logs to see if there are hidden errors that you aren't seeing.

saintiss’s picture

Hi,

Thanks for your suggestions.

It seems the problem was on the server configuration (not our responsibility).

Still, I would like to know how to access the error logs. Through the "reports" menu, I don't seem to find them?

Thanks,
Hans

bfroehle’s picture

@saintiss: The PHP error logs are provided by your web host.

mvreux’s picture

Hello, i just had the exact same problem after copying a drupal installation to another server:

Symptoms:

- Website works perfectly in read-only.
- Can authenticate as an admin fine.
- Overlay is not working: firebug net tab is saying the url called sends an error 404, then i'm redirected to a version of the edit that's the same as if i didn't have javascript enabled.
- No change can be saved, be it articles or website configuration, including disabling of overlay.
- No error is reported by the website itself.
- Apache/php logs aren't showing much, except rare errors like this:

[Fri Aug 05 11:09:50 2011] [error] [client 62.72.x.x] File does not exist: /home/www/Drupal/mySite/node, referer: http://mysite.example.com/

More infos:

- It should be noted that i all i did was copy a website that was working fine from one server to another (sources + database). It worked fine on the first server, but not on the second.
- I know it's not db related, since i configured the same database on a working instance and the faulty one, without changes.
- All the files of the faulty drupal install have been recursively set with a 777 permission, so this shouldn't be a permissions related issue.

Any ideas?

mdupont’s picture

Apache configuration issue, either from httpd.conf, VirtualHost configuration or .htaccess. If AllowOverride is set to None, Apache won't take .htaccess files into account.

lyricnz’s picture

Status: Active » Postponed (maintainer needs more info)

@mvreux: it looks like your new webserver is not working with clean urls (i.e. http://yoursite/node won't work but http://yoursite/?q=node does). Did you remember to copy /.htaccess? It's a hidden file. Otherwise your server needs to be configured to read this file.

mvreux’s picture

Thanks for swift answers! :)

The .htaccess is indeed there (other wise, i could only access the homepage of the website),
Clean urls are working, since i can access pages like /node/60 and also the ones with a pathauto url, like /content/my-rewritten-url
My virtualhost file seems to be fine, it looks like this:

<VirtualHost *:80>
ServerAdmin mvreux@mysite.com
ServerName mysite.example.com
DocumentRoot /home/www/Drupal/mysite
<Directory /home/www/Drupal/mysite>
        Options Indexes FollowSymLinks Multiviews
        AllowOverride All
        Order allow,deny
        allow from all
</Directory>
ErrorLog /var/log/apache2/mysite-error.log
LogLevel debug
CustomLog /var/log/apache2/mysite-access.log combined
</VirtualHost>

I compared the config files apache2.conf et ports.conf, no difference. /etc/apache2/httpd.conf is empty for both the working and broken drupal.

lyricnz’s picture

Did you check that your file-system settings are suitable to the new web-server? Temporary directory in particular, as well as public/private files.

mvreux’s picture

I found the problem! It seems the rewrite module from apache ( mod_rewrite ) wasn't activated...which is kinda weird, since it looked like it was already activated: all pages with a rewritten url like http://mysite.example.com/mypage were working already!

mdupont’s picture

Status: Postponed (maintainer needs more info) » Fixed

Fixed then ?

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

pal4life’s picture

Hi,
So how did you activate that module?

Thanks.