Hi,
I am trying to install Drupal 7.0 on Windows 7 - 64 bit. I have installed Appserv 2.6.0 which consists of:
-Apache 2.2.8
-PHP 6.0.0-dev
-MySQL 6.0.4-alpha
-phpMyAdmin-2.10.3

I have gone through the complete system requirements and done all the mentioned steps (including the setup of php.ini and creation of DB) but, when installing, after writing down the name of the DB, user and password I get the following error:

PDOException: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY fit DESC LIMIT 0, 1' at line 1: SELECT * FROM {menu_router} WHERE path IN () ORDER BY fit DESC LIMIT 0, 1; Array ( ) in menu_get_item() (line 443 ....

I have tried several times to uninstall everything and start from the scratch again. Also, I tried with other versions of Appserv and other versions of Drupal but had no luck.

I need to install it in order to start using it for my organization (+5000 people) so that's why I set it as critical. Without our site we won't be able to make the officil 2011 kick-off.

I would really apprecciate if you can provide me support.

Regards,
Alejandro.

Comments

bfroehle’s picture

Alejandro: Perhaps it is related to #619542: Malformed theme .info files break menu_router generation?

I'd suggest trying to install using a fresh download of Drupal 7, clean database, and NO contributed module or themes. Then add some modules and themes and make sure everything continues to work.

kinsbru’s picture

Status: Active » Fixed

Hi All,
The issue was related to the version of Appserv since it containg PHP 6 which is still under development.
What I did was to change to the previous version of AppServ to 2.5.10 and it works perfectlly fine.
Regards, Alejandro.

pingers’s picture

Status: Fixed » Closed (fixed)

Closing.

JLambrecht’s picture

What do you mean by Appserv ?

I have the same error on Debian SQueeze but don't believe i have Appserv installed.

JLambrecht’s picture

http://drupal.org/node/1130348 has some pointers that made it work for me, let me know if you need more