Closed (fixed)
Project:
Drupad
Version:
7.x-1.2
Component:
iPhone app
Priority:
Normal
Category:
Support request
Assigned:
Unassigned
Reporter:
Created:
22 Jun 2011 at 10:54 UTC
Updated:
5 Jan 2012 at 11:02 UTC
Hello.
When I try and log in from the iPhone, I get "Oops - The request did not succeed."
I have 7.x-1.2 version installed.
I have tried the following
I'm running a fresh Drupal 7 install on a fresh CentOS machine.
Can you assist?
Comments
Comment #1
mattieo commentedHello! :-) Anyone there?
Comment #2
jchatard commentedHi mattieo,
Some users have reported the same kind of issue, they tried to uninstall completely the app from their iPhone/iPod. Re-download it (you won't pay again) and everything seemed to work again.
Can you try this?
Thanks,
Jérémy
Comment #3
iNik commentedI'm having the same problem. I have uninstalled and reinstalled both drupad module and the iPhone application. I am running v7 on Dreamhost.
Comment #4
jchatard commentedHi iNik,
Did you try code snippets described in the install page?
Comment #5
iNik commentedYes. Both. Cleared caches following each.
The one problem with the snippets is taht under D7, there is no rewrite rule for "...?q=..." as there is in 6, so I just put it at the end if the rewrite rules (just before the ""). Not sure whether there are other snippets for D7.
Comment #6
jchatard commentedHmm, yeah you're right.
This is extracted from .htaccess of Drupal 7:
This forwards clean URLs management to
drupal_environment_initialize()in bootstrap.inc, which usesrequest_path()(also from boostrap.inc).Can you try code snippet #2 just before this block (I don't have a (F)CGI PHP hosting)?
If this solves the problem with iOS app, can you check this has no incidence on other components of your Drupal instance?
I'm not an export in RewriteRules and CGI stuff, so if any guru could help us. That would be awesome.
Thanks,
Comment #7
iNik commentedThis did not address it. However, I did move my site to a server that used mod_php, and it worked out of the box. Curious.
Comment #8
jchatard commented@mattieo any news?
Comment #9
lp commentedI had login issues as well under PHP 5 FCGI. My shared domain manager control panel says PHP 5.3, php.info says 5.2.17, also w/mod_security.
I was seeing:
"Oops Login failed, please check your login and password."
I was confused by the apparently D6 specific directions in README.txt.
#6 fixed it up for me. I didn't even have to restart the app.
The site seems to be functioning fine elsewhere, unless there's a specific scenario I should be testing.
App looks fantastic, thanks!
Comment #10
simondoyle commented#6 worked fine for me with an FGCI install of Drupal 7.8 on Ubuntu 10.04.
The app looks very useful... Thanks...
Comment #11
jozzhart commented#6 worked fine for me too
Comment #12
jchatard commentedGo here please: http://drupad.com/install.html