I am not sure if this is a core issue or a module issue. that´s why I first post it here.
Situation: I had problems with the media-gallery and deinstalled styles, media, media-gallery and then tried to reinstall the modules.
Server is Apache (MAMP on OSX), PHP is 5.2.13
Reinstalling/Enabling Media-Gallery still fails with this error:
And a lot other errors are now coming up:
Fatal error: Cannot access empty property in /Applications/MAMP/htdocs/drupal-7.0-beta/modules/field/field.attach.inc on line 661
FieldException: Attempt to purge a field media_description that still has instances. in field_purge_field() (line 1141 of /Applications/MAMP/htdocs/drupal-7.0-beta/modules/field/field.crud.inc).
Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/drupal-7.0-beta/includes/common.inc:2512) in drupal_send_headers() (line 1028 of /Applications/MAMP/htdocs/drupal-7.0-beta/includes/bootstrap.inc).
Besides cron is not working anymore: The website encountered an unexpected error. Please try again later.
| Comment | File | Size | Author |
|---|---|---|---|
| #6 | 20101118_d7b3-qa-issues.gif | 19.38 KB | drupa11y |
Comments
Comment #1
drupa11y commentedAnd some more while checking updates:
An AJAX HTTP error occurred. HTTP Result Code: 200 Debugging information follows. Path: /batch?id=118&op=do StatusText: OK ResponseText: {"status":true,"percentage":"1","message":"Trying to check available update data ...\u003cbr \/\u003eChecked available update data for \u003cem class=\"placeholder\"\u003eLink\u003c\/em\u003e."}FieldException: Attempt to purge a field media_description that still has instances. in field_purge_field() (line 1141 of /Applications/MAMP/htdocs/drupal-7.0-beta/modules/field/field.crud.inc).
Comment #2
int commentedThis is a media bug, not drupal core.
Comment #3
JacobSingh commenteduninstalling is pretty untested in most of these modules and unsupported until we release a 1.0 I think. It would be great if you were able to root out the issues, but it's not obvious right now how to fix them quickly.
Best,
Jacob
Comment #4
minus commentedFresh install, of drupal 7 beta 3 and media modul 7.x-1.0-beta2, 7.x-1.x-dev, Entity CRUD API 7.x-1.0-beta1 and Entity Metadata 7.x-1.0-beta1.
After installing the modules I added a new Multimedia asset field to the default content type Article. When creating a new article and try to upload a file through Imagemedia - select media button, I get the following error messages uploading a .jpg file:
Overlay disappears and gives me a transparent screen.
Comment #5
JacobSingh commentedPlease read the top of the project page.
Comment #6
drupa11y commentedWill keep an eye on it and maybe other modules like "Q&A" had to do something with it.
Some errors had gone after disabling "Q&A" -> see nice attachment.
I´ll do some test on a cleaner installation within next 2 weeks.
At the moment I am very happy to keep "rotating banner" running and don´t need the galleries.
Happy coding !!!
Comment #7
drupa11y commentedPS: I did not find a possibility to delete a created "rotating banner"-block
Comment #8
drupa11y commentedInstalling & Enabling on a nearly clean subdomain with only a few modules, did not show up any errors or warnings. Let´s see what happens when adding content & then uninstalling.
But please be patient until next week.
Comment #9
effulgentsia commented@mori: thanks again for testing and reporting issues. Any update on whether there's any remaining problems related to this issue? I'm trying to close out remaining criticals to clear the way for a 1.0 release. Thanks!
Comment #10
effulgentsia commentedComment #11
effulgentsia commentedComment #12
effulgentsia commentedMarked #1021250: De-installation needs work a duplicate: it contains additional info about the same problem.
Comment #13
Aonoa commentedUsing a fresh default D7.0 site with styles-7.x-2.0-alpha4, enabling, disabling and uninstalling latest media-HEAD worked without errors for me. I think this issue is outdated, but I did not add any content or mix in the other media modules.
Best regards,
Ao
Comment #14
Aonoa commentedI was going to test uninstalling after enabling more modules and adding some content, but media: youtube fails to uninstall, thus making it impossible to attempt uninstallation of the media module. I may re-install the demo site and avoid installing media: youtube to re-test uninstalling media.
(Fatal error: Class 'MediaInternetBaseHandler' not found in /var/www/example.com/drupal-7.0/sites/all/modules/media_youtube/media_youtube.module on line 253)
Best regards,
Ao
Comment #15
zuzu83 commentedhttp://drupal.org/node/970696 I think the problem is related
Comment #16
JacobSingh commentedIndeed, that other issue is a better one for the same thing.
#970696: Disabling and re-enabling media module throws exceptions, leaves website in unusable state.
Comment #17
416areacode commentedI'm looking to disable and then uninstall media module and chaos tools - (both are greyed out in module section of backend).. I need a specific walk through to clean house of these two modules
Comment #18
hedel commentedhere too is not possible to uninstall
media 1.4.
I can't delete the content type the module created