Not really a problem, just wanted to clarify which mysql version I should use. I used 4.0 on my localhost. I'm using 1 and 1 hosting server. I noticed in the 4.7.4 drupal database folder there are only options for mysql 4.0 and 4.1. I ran the info.php for my 1 and 1 server and it came back with PHP Version 4.4.4. Just out of curiosity, why isn't 5.0 included with drupal? Not that this makes much difference to me as I'm such a newbie. I just want to use the most secure version. So main question is 4.0 or 4.1? Thanks.

Comments

inforeto’s picture

I have mysql 5.0 and used the 4.1 file to create the database without problem.

kitt’s picture

Active support for MySQL 4.0 and earlier by MySQL AB (http://mysql.com/) ended last month. If you have problems with these databases and need real support for them (through MySQL AB in particular), you'll need to pay for the support. So, rather than use a product that's outdated, go with 4.1 or later, 5.0 or later if you can.

noraa’s picture

Thanks both of you. For some reason I got an error when I tried 4.1, so I installed 4.0 just to get things running. Of course, I did't note the error, but it gave me a line number (error at line....), so don't know if it was the actual file from the drupal/database directory or if it's my host. 4.0 installed quite fine. I think I remember this happening on my localhost also. I guess I'll have to investigate. But at least I got my shell of a site up.

inforeto’s picture

Perhaps it'd be worth a retry, otherwise it'd burden future site migrations.

I recall there were differences between sql code for 4.0 and 4.1, namely the collation on the tables.
Back then i wasn't using drupal, so i had to update my php code and mysql tables to add the collations.
But more recently i updated from 4.1 to 5.0 and everything worked as it was (using drupal 4.7.3)

noraa’s picture

Hmmm, good point. I might as well get it resolved before I go much further. It's just a clean install I have up right now. Are people moving to 5.0 with confidence now? I don't know squat about these things (as far as version differences), but it seems I read where people were wary of it because of its newness awhile back. Also, if my host is on 4.4.4 am I locked into 4.1?