Hi there,

when updating Panels+CTools (both were enabled before - of course I updated them at the same time), I got a WSOD at fist.
After I could overcome that by removing them from the modules folder and trying to re-install them / update them, I got:

********
The following queries were executed
panels module
Update #6310

* Failed: Panels cannot be updated because CTools 1.7 (API v1.7.2) is required. Please update CTools and then try update.php again.
********

I double-checked that I got the last version for BOTH and updated them at the same time.
What's even more strange - both panels and Ctools are now inactive in the modules administration and can't be activated.

I run cron and tried to update, plus I tried this with both the latest stable and dev versions. No success.

Thanks for any help.

Robert

Files: 
CommentFileSizeAuthor
#3 Picture 2.jpg28.67 KByvesdc

Comments

merlinofchaos’s picture

"can't be activated." -- what does this mean? What happens when you try to activate them?

yvesdc’s picture

I have exactly the same, I run update and I get a failure notice saying "Panels cannot be updated because CTools 1.7 (API v1.7.2) is required", see the attached image.

yvesdc’s picture

StatusFileSize
new28.67 KB
merlinofchaos’s picture

#2: Not to be pedantic, but the message states a problem and a solution. Did you attempt the solution? If you did, you failed to actually say anything. If you did not, why did you not attempt the solution?

merlinofchaos’s picture

Status:Active» Postponed (maintainer needs more info)
j0nathan’s picture

Status:Postponed (maintainer needs more info)» Closed (duplicate)
murokoma’s picture

Status:Closed (duplicate)» Needs review

Hi there,

confirmed that the "solution" in the screenshot did NOT help as 1.7.2 already WAS there (using the last versions of both panels and ctools);
the mentioned Patch helped solve the "update error" issue, however I still can't activate panels?

Greets,
Robert

Screentshots:

Panels inactive:
http://screencast.com/t/NTNmMDA3N

ctools inactive
http://screencast.com/t/N2MzMzU2

chien_fu’s picture

I get the same panels inactive screenshot from above.

Stomper’s picture

Hi,

I got the same error as above (upgrading from 6.15 to 6.19):

********
The following queries were executed
panels module
Update #6310

* Failed: Panels cannot be updated because CTools 1.7 (API v1.7.2) is required. Please update CTools and then try update.php again.
********

I tried "activating" Ctools based on merlinofchaos' suggestion (#1)[I went into modules, selected Chaos Tools, save configurations] and got this when I ran update.php again:

********
The following queries were executed
panels module
Update #6310

no queries
********

Does that mean the issue has been fixed?

I ran update.php a third time to confirm the message but now nothing shows up error-wise in the update log. Does that mean everything is okay?

I went back to modules to reactivate my modules and noticed that Stylizer had been activated under Chaos Tools Suite, I am sure I did not activate it earlier, only Chaos Tools. Is that normal?

Thanks

merlinofchaos’s picture

Status:Needs review» Active

Sigh. Changing from wrong status.

merlinofchaos’s picture

#9: That looks like things should be okay. Stylizer probably got activated because the (now deprecated) stylizer module from Panels turned it on for you so that any usage of the module you previously had would continue to function.

Letharion’s picture

Status:Active» Closed (won't fix)

In an effort to clean up the many hundreds of open issues in the Panels queue, I'm going over all bug reports. If they haven't been updated in over a full year,
I'm going to assume that they no longar affect any one, and close it. I realise that some issues will be closed, that should remain open.
If this is the case, and you still have an interest in this issue, please just re-open it, setting the appropriate status, and providing exports and detailed instructions for reproducing the error.