After installing the update 3.1, I get multiple warning messages when I edit a node:
warning: Invalid argument supplied for foreach() in /usr/www/users/hdluser/service/sites/all/modules/hierarchical_select/modules/hs_taxonomy.module on line 440.

Gone through troubleshooting in the Readme fiel, but did not find a solution. See screenshots.

warnings.png79.81 KBchiefkong
status.png128.83 KBchiefkong


Wim Leers’s picture

Title:warning: Invalid argument» Bug in Term Permissions support for Hierarchical Select Taxonomy
Assigned:chiefkong» Wim Leers
Status:Active» Fixed

You have the Term Permissions module installed.

HS has Term Permissions support since #505090: Term Permissions support for Hierarchical Select Taxonomy. There's a bug in the code that went undetected for >1 month in 6.x-1-x-dev. Which indicates how many people actually use this …

Patch that fixes this attached. And committed:

chiefkong’s picture

Thank you, that was the clue.

It turned out that I didn't even need the Term Permissions Module. Just left on while developing the site. Now I turned it of and all works fine.

Wim Leers’s picture

Can you please re-enable it and confirm that the change I made fixed the bug? :) That'd be very helpful and cost you only a few minutes of your time. Thanks!

chiefkong’s picture

Your patch works. I enabled the Term Permissions module again, applied your patch and the warning messages are still gone. So the patch works fine.

Thank You again.

Wim Leers’s picture

Thanks for taking the time to confirm this! :)

Status:Fixed» Closed (fixed)
Issue tags:-update, -warning

Automatically closed -- issue fixed for 2 weeks with no activity.