Hey,

I want to use this theme. However, when I add a block to sidebar last, all of my content (blogs, stories, etc) drop below the sidebar last. Does anyone know why this is happening?

Comments

dman’s picture

Priority:Critical» Normal

Here's the FAQ to start with.

tavousi’s picture

Title:Why does all my content drop below sidebar last?» thank u.but my problem is in RTL style.

thank u.but my problem is in RTL style.

tavousi’s picture

Title:thank u.but my problem is in RTL style. » Why does all my content drop below sidebar last?
tavousi’s picture

Title:Why does all my content drop below sidebar last?» Why does all my content in RTL style drop below sidebar last?
Priority:Normal» Critical

hi

i am in critical priority.please help me & other in RTL style.

than u

W.M.’s picture

I am also experiencing problems on a RTL site and that is only on IE (6 & 7) (Firefox & Chrome are fine).

The book navigation block gets placed at far left side of page (instead of right). The drop down menus get also placed to the left of the top buttons (Again only in IE 6 & 7)

Hope a fix will be released!

Thanks for great work!

fuquam’s picture

Subscribing. Same problem only in IE7 (didn't test 6). Also the content area of the blocks in the sidebar-first area are extending beyond the 240px width. Since the width is set I don't know how or why. I'd be interested to know if this is happening to anyone else.

W.M.’s picture

Why is it that it's often IE that shows problems?! The unfortunate thing is that most of my visitors use IE...

fuquam’s picture

IE is a piece of crap browser that doesn't care about web standards, current css, or security for that matter. Designing css hacks for IE has used up way too much of my time the last few years. Most people use IE because their computer comes with WinBlows and IE installed. Check out the IE Destroyer module http://drupal.org/project/iedestroyer for some comic relief. Anyway IE7 seems to be a little better. At least my main content area isn't dropping below the sidebar_last in IE7, just IE6.

W.M.’s picture

I hope someone will provide help here.. It's a great theme and i would love to have it at my site. Here are some screenshots as how the theme appears in IE 7 on an Arabic language RTL site:

http://www.imagebam.com/image/7ae04353552776
http://www.imagebam.com/image/d7097453552777
http://www.imagebam.com/image/8adfc953552778
http://www.imagebam.com/image/eaa8e653552779

The login boxes (username & password) get thrown away to far left side of page as the mouse moves over the blue "submit" button. When logged in the navigation menu is also put at far left side of page instead of being placed inside the box/block in the right side.

The problem is seen in IE 7 / IE 6 (I Don't know about IE 8). The theme works fine in Firefox & Chrome.

Hope this help you to resolve the problem. I have tested the 6.x-2.0dev theme and it shows the same problems. I will assist you further with continuous feedback.

W.M.’s picture

Title:Why does all my content in RTL style drop below sidebar last?» Here is some information that might help!

The problem I have described earlier that navigation menu jumping and getting placed under sidebar-last (i.e. left side of a RTL site) is seen in IE 6 & 7 only WHEN "dhtml menu" module is used. The problem disappears as that module is disabled.

There are still some issues of theme icons being placed incorrectly when viewing the site using IE 6. In addition, the left border of the blocks (on right side) are trimmed (hidden partially behind something)...

Any suggestions?! I will be happy to try any modifications and giving feedback!

W.M.’s picture

Title:Here is some information that might help!» Why does all my content in RTL style drop below sidebar last?
zisser’s picture

I see the same issues..
Any hope in the near future?
This problem limits me to use only sidebar first which is not enough..

Anyone here can recommend a good RTL theme?

W.M.’s picture

@Zisser
Are you using DHTML menu module?!

zisser’s picture

I noticed the problem few weeks ago and removed it..
I'm having problems in IE6 and IE7 as you are.

I'm desperate looking for a new RTL compatible theme I can use instead.
Its a shame as I really love this theme.

Udi

W.M.’s picture

@Zisser

I had experienced similar problems with this module only when I had dhtml_menu enabled. Once I disabled this module the problems with acquia marina were gone. Maybe you have a module conflicting with this theme...

It's working fine on my site now...

jwolf’s picture

Priority:Critical» Normal
Issue tags:+RTL
W.M.’s picture

It looks like that the recent alpha release solves the problems on RTL sites...

jwolf’s picture

Version:6.x-1.9» 6.x-3.0-alpha1
Status:Active» Fixed

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

alexarpen’s picture

Priority:Critical» Normal
alexarpen’s picture

Category:bug» support
Priority:Normal» Critical
Status:Closed (fixed)» Active

i have the same issue. anything falls beyond the sidebar in the RTL page!!

1. it has no business with DHTML menu.

2. i re-opened the request.

3. I have problem in IE6. it is really critical. the sidebar i have problem with, is my Main sidebar.

eternalistic’s picture

Priority:Normal» Critical

Have you tried the Acquia Marina 3.x version to see if it corrects the issue? If not please give that a try and let us know how it does.

alexarpen’s picture

Assigned:tavousi» Unassigned
Status:Active» Fixed

I found the solution for my case:

it was a

div.block {position:relative;}

in one of genesis theme's css. i just removed all the genesis css files!!

look in all css includes in your page for something like this.

i found the buggy line like this:

i opened the page in IE --> view source --> copy the source --> open page.tpl.php (first make a backup) --> paste the copied source onto it! --> line by line comment the link rel="stylesheet" tags and check your site. --> at the line that sidebar content appears stop --> go through the found buggy file.

Status:Fixed» Closed (fixed)
Issue tags:-RTL

Automatically closed -- issue fixed for 2 weeks with no activity.