I think the text used in the "per content access control settings" area on the "Access control" tab for content types is a bit confusing. It can probably be improved by using the phrase "per node" instead of "per content".

In lieu of a proper patch, here's the change, starting on line 109 of content_access.admin.inc:

  // Per node:
  $form['node'] = array(
    '#type' => 'fieldset',
    '#title' => t('Per node access control settings'),
    '#collapsible' => TRUE,
    '#description' => t('Optionally you can enable per node access control settings. If enabled, a new tab for the content access settings appears when viewing nodes. You can configure permissions to access these settings at the !permissions page.', array('!permissions' => l(t('permissions'), 'admin/user/permissions'))),
  );
  $form['node']['per_node'] = array(
    '#type' => 'checkbox',
    '#title' => t('Enable per node access control settings'),
    '#default_value' => content_access_get_settings('per_node', $type),
  );

-mike

Comments

apaderno’s picture

Title: Improved title and description for "per access access control settings" » Improve the title and description for "per content access control settings"

I agree; node is the word that is normally used in Drupal jargon.

fago’s picture

Status: Active » Fixed

I disagree - there is no normal jargon, even core doesn't use a single terminology. However I improved it to talk about "content nodes".

Thanks for your suggestions!

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.