Problem/Motivation
Fantastic with the new release, thanks!
It does look like a previous version (3.5?) may have had the "Supported" check-mark removed, which triggers warning email alerts ...
The installed version of at least one of your modules or themes is no longer supported. Upgrading or uninstalling is strongly recommended. See the project homepage for more details.
See the available updates page for more information:
https://example.org/admin/reports/updatesYour site is currently configured to send these emails only when security updates are available. To get notified for any available updates, https://example.org/admin/reports/updates/settings.
Under Available updates
Release not supported: Your currently installed release is now unsupported, and is no longer available for download. Uninstalling everything included in this release or upgrading is strongly recommended!
Includes: Admin Toolbar, Admin Toolbar Extra Tools, Admin Toolbar Search
https://example.org/admin/reports/updates
Steps to reproduce
Get email warnings about security update, see warnings on Update page.
Proposed resolution
Set 3.5 (3.5.2?) to "Supported", since it works fine. It's just not the latest release.
Remaining tasks
I tried to raise this issue, but it seems like the interface still does not convey the consequences of removing "Supported" effectively?
Comments
Comment #2
ressaComment #3
ressaComment #4
ressaRemoving already added link.
Comment #5
dydave commentedThanks @ressa!
Sorry for the noise with the emails: I've made the change immediately on the administer releases page.
I hesitated to change this yesterday after creating the release 😅
Turns out I should not have changed this.
Could you please double check again and see if it is better now?
Thanks in advance!
Comment #6
ressaPerfect, it's much better now, and the warning is gone. Thanks!
Comment #7
dydave commentedThanks a lot @ressa for catching this so quickly, before we got a storm of angry messages 😅
I've set the 3.4.x release unsupported instead, so we only show the last two releases supported on the project page:
3.5.3 (3.5.x) and 3.6.0 (3.6.x)
Let me know if you catch anything else, I will be monitoring the issues closely and try to answer as soon as possible for urgent requests 👌
Marking issue as Fixed for now.
Thanks again for your great help @ressa! 🙏
Comment #8
nojj commentedI am still on V3.4.2. an got this warning.
how can I update to V3.5.3 ?
if I require it with composer, composer wants to install V3.6
Comment #9
ressaThanks for a quick update @dydave, that sounds like a good decision, which should prevent angry messages :) Since 3.4 is from September 2023, that setting ought to be all right.
@nojj: Can't you just update to 3.6? If not, you can use the Composer command on https://www.drupal.org/project/admin_toolbar/releases/3.5.3 for version 3.5.
Comment #10
nojj commented@ressa I just don't want to deal with this at 3.6
when running
composer require 'drupal/admin_toolbar:^3.5'composer always requires V3.6
Comment #11
dydave commentedOK, no problem, thanks @nojj
Could you maybe try the following command?
composer require 'drupal/admin_toolbar:3.5.3'Thanks in advance!
Comment #12
nojj commented@dydave thanks.
composer require 'drupal/admin_toolbar:3.5.3'requires V3.5.3.
I thought it would be bad practice, to require a specific version as this would not be updated to e.g. V 3.5.4
Comment #13
dydave commentedThanks @nojj for the prompt feedback and glad it worked!
Not really no.... it's OK to use a fixed version, we call this "pinned", since in some cases your site might be running a bit behind certain versions.
Indeed, in your following updates you might have to change the version constraint again to upgrade the module.
But you can probably deal with that a bit later, once you have a bit more time to figure out what could be breaking on your site with 3.6.0.
Thanks again for the feedback!