Apparently due to a Core change PHPStan currently reports a warning for all our pipelines. Apparently, the ignored error pattern #^Plugin definitions cannot be altered\.$# is not matched anymore in SearchApiPluginManager.php – apparently PHPStan (or its config) is now smart enough to realize that this is not a real problem.

Issue fork search_api-3494226

Command icon Show commands

Start within a Git clone of the project using the version control instructions.

Or, if you do not have SSH keys set up on git.drupalcode.org:

Comments

drunken monkey created an issue. See original summary.

drunken monkey’s picture

Status: Active » Needs review

Created an MR, let’s see how the pipeline fares.

Note to self: Need to re-disable testing against the other Drupal versions.

drunken monkey’s picture

Status: Needs review » Fixed
drunken monkey’s picture

Regarding the CSpell error, I commented in #3494834-13: Add common words not in core dictionaries and hope this will just be resolved on a global basis. I suspect this is currently biting a lot of modules.

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.