Closed (fixed)
Project:
Custom Field
Version:
3.0.x-dev
Component:
Code
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
2 Jun 2024 at 18:22 UTC
Updated:
21 Jul 2024 at 10:29 UTC
Jump to comment: Most recent, Most recent file
Comments
Comment #2
deepak5423 commented@ady1503 Can you please elaborate on the reproducing steps because I cannot?
Comment #3
ady1503 commentedIt is simple.
Just add a number field and that's it.
This error appears when saving the new node also when editing.
And very important:
That the error is repeated for each field number of the custom_field in the same content type.
I also saw a strange thing.
When you create a new content type and save it, the keys appear and not the values. But if you go to Manage Presentation and simply change the presentation to key in any number field and save, all the number fields show the value and the one you changed shows the key, and then you put it back to value, everything is normal. You have to repeat this matter if you have added another number field, so that all the number fields present the values and not the keys.
These errors appear only the first time when creating a new content type. Then they no longer appear.
Create a new content type, add a custom_field of number format.
Create the first one, and you will see the error, edit it and the error appears. But the following new ones created and edited no longer appear.
Gracias.
Comment #6
apmsooner commented@ady1503, This patch should fix if you would kindly test. Thanks
Comment #7
apmsooner commentedComment #8
jonasanne commentedI tested this on 10.2.6 with php 8.1 (branch 2.0.x and branch 3.0.x) and on 10.3.0 with 8.3 while following the steps above and I do not have the error.
Comment #10
apmsooner commentedComment #11
ady1503 commentedI confirm all working.
Thanks for this module.