Closed (fixed)
Project:
Search API
Version:
8.x-1.x-dev
Component:
Framework
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
18 Oct 2023 at 00:09 UTC
Updated:
13 Nov 2023 at 21:02 UTC
Jump to comment: Most recent, Most recent file
Comments
Comment #2
bobburns commentedComment #3
joinso commentedSame error here.
Rollback to 1.29
Comment #4
bsingh commentedSame error!
Comment #5
grzesag commentedI upgraded from 1.29 to 1.30 on Drupal 10.1.5 and looks good to me
are you seeing this for Drupal 10.1.5? where do you see this error? Settings or when searching?
Thanks
Comment #6
bwong commentedSame issue on Drupal 9.5.11. Moved back to 1.28
Comment #7
geoffray commentedSame issue after upgrading from v1.28 / Drupal 9.4.15 to v1.30 / Drupal 9.5.11
Comment #8
bobburns commentedComment #9
bobburns commentedISSUE FOUND - ADD
use Drupal\search_api\Utility\DataTypeHelperInterface;
use Drupal\search_api\Utility\ThemeSwitcherInterface;
to top of modules/search_api/src/Utility/FieldsHelper.php
BUT . . .
The errors in the 2 Upgrade Status JPG snip shot uploads need address and added to a new release along with the fix above
Comment #10
bobburns commentedSearch api errors from Upgrade Status - coding deeper than I want to go to fix
Comment #11
bobburns commentedComment #12
drunken monkeyYou’re right, thanks a lot for reporting!
Forgot again that we cannot just change the constructor parameters of services …
Proper way is a deprecation – patch attached and change record created. Please test/review!
I’ll create a 1.31 release right away after committing this.
Comment #13
niki v commentedI just ran into this error after doing some upgrades on a local d10 site. I can confirm that the patch solved it
Comment #14
chris64Same main error message in #3396338: Search_api error from drush errp.
Comment #16
drunken monkeyThanks for reporting back, good to hear it worked.
Merged.
(Since #3388678: Performance issues after fixing 'PHP 8.1 preg_replace()' issue is also a regression, though, I think I’m gonna wait for that until creating a new release.)
Comment #18
ronraney commentedI just used this patch in #12 because I was seeing the error for search_api version ^1.30.
After the patch is installed using composer, now I'm seeing this: