Problem/Motivation
Updating Drupal core from 10.1.1 to 10.1.2 causes Unami-based site to throw a 500 error and report
The website encountered an unexpected error. Please try again later.
Twig\Error\LoaderError: Template "umami:branding" is not defined.
Steps to reproduce
- Have a Drupal 10 site at v10.1.1 running Unami.
- Run composer update to update Drupal core to 10.1.2.
- Deploy
More details
We have a basic Drupal 10 site that was set up with Unami. During our normal, daily update process, the Drupal 10 PR environment threw an error:
Twig\Error\LoaderError: Template "umami:branding" is not defined.
drush -y cache-rebuild is part of the deploy.
In looking at what updated it appears
- drupal core had a minor update from 10.1.1 to 10.1.2
- guzzle promises had a minor update from 2.0.0 to 2.0.1
- guzzle psr7 had a minor update from 2.5.0 to 2.5.1
- mck89/peast had a minor update from 1.15.2 to 1.15.3
Digging into the recent changes, added by lauriii, it appears the SDC module was added for Unami, but no update hook was included to ensure the SDC module was enabled.
Running drush en sdc "fixes" the issue, but considering this was slipstreamed into a patch version, end users shouldnt be expected to do this manually.
System Details
OS:
$ cat /etc/issue
Debian GNU/Linux 10PHP: 8.1
Comments
Comment #2
gilzow commentedComment #3
longwaveUmami is experimental and meant for demo use only, we have never intended to support upgrades between versions for sites using it.
See https://www.drupal.org/docs/getting-started/umami-drupal-demonstration-i...
Leaving this open for now for other committers to comment; to me this is works as designed and while we could start adding update hooks to Umami I think we only ever intended it to be installed on a single version.
Comment #4
rfayTotally agreed @longwave, but the flip side is the entire ecosystem has become dependent on Umami because it's so great for demo environments. We all use it like crazy for everything. Maybe it's so very good that it should be promoted from experimental. Obviously it's not for production, but that doesn't mean it's not as valuable as something that should be for production.
Comment #5
markconroy commentedUmami maintainer here!
I'm fine with this being closed as "Works as designed" as we are perpetually experimental and not providing updates.
However, to fix the issue reported, I reckon you can install the SDC (Single Directory Components) module that is available (also experiemental for now) from Drupal 10.1. Can you check if that fixes your issue please?
Comment #6
cilefen commentedComment #7
mupsiHey there! I successfully migrated a D9 Umami to D10, so I can confirm that enabling the SDC module fixes the issue as expected. The ticket was opened more to signal the fact that it had to be done manually and that no upgrade path was available but I saw the exchanges above as to why that is :)
Comment #9
quietone commentedAfter reading the comments I am closing this as works as designed, as stated by a Umami maintainer.
This is a good reminder that Umami is a demo with no update path.
Comment #10
drupalvikingEven as closed, I wanted to comment on the SDC part. Since SDC is now part of Core, all you have to do is update to 10.3.x branch and you don't even need SDC module ;-)
My Umami site was broken for a long time because I didn't read this thread :-) But upgrading to 10.4.0 just fixed everything again! So yes, SDC broke it, but 10.3 will again make it work as designed.