Problem/Motivation
@rkoller brought this up in slack
Right now on all admin pages you will see the summary of the readiness checks if any flag a validation error/warning
The intention was that you should know as soon as possible if your site will not be automatically updated because admins will be relying on this to apply security updates and you don't want to be surprised after a security update is released.
but now after #3239103: Add setting to enable/disable updates on cron some sites will have cron updates disabled altogether and will only be using this module to update via the form.
In that case are the readiness checks still important enough to display on all admin pages?
The checks will still display on the status report page and when the user goes to the update form.
Proposed resolution
Do not display readiness checks on admin page if the cron updates are disabled.
Also if cron updates are disabled and not displayed on admin pages then they also don't need to be run on cron. They are only run on cron so that they don't have to run on all admin pages.
Remaining tasks
Decide on the correct behavior
User interface changes
If cron updates are disabled readiness checks will not display on admin pages.
Issue fork automatic_updates-3244679
Show commands
Start within a Git clone of the project using the version control instructions.
Or, if you do not have SSH keys set up on git.drupalcode.org:
Comments
Comment #3
tedbowComment #5
tedbowComment #6
rkollerhm i've applied the diff in #4 as well as i've applied the diff right after your last two commits in #5 but somehow the error message is still showing up while automatically update drupal core is disabled and the cron status shows cron last ran 1 hour 5 minutes ago. :/ (tested still on the drupal 9.3.x-dev install).
Comment #7
tedbow@rkoller thanks for testing.
Yes I just had a
!==when it should have been a===. Should be fixed nowComment #8
rkollerI've applied the patch and the appearance of error messages with "Automatically update Drupal core" disabled seems correct and working now. the only two occasions the error shows up is on
admin/reports/updates/automatic-updateandadmin/reports/status. That seems the correct behavior and amount of information to me. I leave the status at needs review since i am not able to provide a code review as well unfortunately :)Comment #9
tedbowComment #10
tedbowComment #11
tedbowComment #13
kunal.sachdev commentedComment #14
tedbowI removed the changes to automatic_updates_cron(). Because otherwise when view the status report we would never have stored results from a cron run. It still may be a good idea to run the checks during cron so they don't have to always run during the status report.
If we want to change this we can open up a new issue.
Comment #16
tedbow