Problem/Motivation
I get a error notice on every Admin page for this module e.g. /admin/config/people/miniorange_saml/idp_setup
Undefined index: REQUEST_SCHEME
Notice: Undefined index: REQUEST_SCHEME in Drupal\miniorange_saml\mo_saml_visualTour::genArray() (line 20 of modules/contrib/miniorange_saml/src/mo_saml_visualTour.php).
(see image attached)
This doesn't happen locally on Apache, but my remote server is nginx, maybe that is part of the issue?
Steps to reproduce
Enable module and navigate to /admin/config/people/miniorange_saml/idp_setup (possibly just on nginx setup?)
Comments
Comment #2
mohit.bansal623 commentedAfter going through various articles for this issue, found out either we can use @ or isset.
https://wordpress.org/support/topic/undefined-index-request_scheme-2/?vi...
Attaching patch, please review.
Comment #3
code-brighton commentedI can confirm this patch fixes the error and the "Module Tour" still works so I think I can mark as fixed. Well done @mohit.bansal623 thanks!
Comment #4
arsh244 commentedThanks for providing the patch. The issue has been resolved in the 8.x-2.22 version of the module.
Comment #5
gauravsood91 commented