Problem/Motivation

I get a error notice on every Admin page for this module e.g. /admin/config/people/miniorange_saml/idp_setup

Undefined index: REQUEST_SCHEME
Notice: Undefined index: REQUEST_SCHEME in Drupal\miniorange_saml\mo_saml_visualTour::genArray() (line 20 of modules/contrib/miniorange_saml/src/mo_saml_visualTour.php).
(see image attached)

This doesn't happen locally on Apache, but my remote server is nginx, maybe that is part of the issue?

Steps to reproduce

Enable module and navigate to /admin/config/people/miniorange_saml/idp_setup (possibly just on nginx setup?)

Comments

code-brighton created an issue. See original summary.

mohit.bansal623’s picture

Status: Active » Needs review
StatusFileSize
new827 bytes

After going through various articles for this issue, found out either we can use @ or isset.
https://wordpress.org/support/topic/undefined-index-request_scheme-2/?vi...

Attaching patch, please review.

code-brighton’s picture

Status: Needs review » Reviewed & tested by the community

I can confirm this patch fixes the error and the "Module Tour" still works so I think I can mark as fixed. Well done @mohit.bansal623 thanks!

arsh244’s picture

Status: Reviewed & tested by the community » Fixed

Thanks for providing the patch. The issue has been resolved in the 8.x-2.22 version of the module.

gauravsood91’s picture

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.