When installing through the Drupal administration panel, the module does not install and gives 500 error.
The error it shows is the following:
2066#2066: *8911 FastCGI sent in stderr: "PHP message: Uncaught PHP Exception Symfony\Component\Routing\Exception\RouteNotFoundException: "Route "view.simplenews_newsletters.page_1" does not exist." at /var/www/html/web/core/lib/Drupal/Core/Routing/RouteProvider.php line 208" while reading response header from upstream, client: 172.18.0.6, server: _, request: "GET /batch?id=16&op=start HTTP/1.1", upstream: "fastcgi://unix:/run/php-fpm.sock:"
The error also occurs in the version: 8.x-2.0-beta1
The way I managed to install the module was by moving the following configurations from optional to install:
- views.view.simplenews_newsletters.yml
- field.storage.node.simplenews_issue.yml
Installing it by drush works, but when done by the administration panel it does not.
| Comment | File | Size | Author |
|---|---|---|---|
| #4 | Simplenews-Uninstall.png | 21.45 KB | bflbarlow |
Comments
Comment #2
gonzalo2683 commentedComment #3
adamps commentedI always use drush and I guess most others do too. Patches welcome.
Comment #4
bflbarlow commentedAfter clicking the "Prepare to Uninstall", my site (as an Admin) become completely inaccessible with the below error message in the browser.
The website encountered an unexpected error. Please try again later.
Symfony\Component\Routing\Exception\RouteNotFoundException: Route "view.simplenews_newsletters.page_1" does not exist. in Drupal\Core\Routing\RouteProvider->getRouteByName() (line 208 of core/lib/Drupal/Core/Routing/RouteProvider.php).
I literally just installed it, created a newsletter, realized it wasn't what I wanted, and went to uninstall it. This seems like an unacceptable issue.
I have seen the solution is to utilize Drush to uninstall? I have never used Drush, so I feel very left-out-to-dry with a completely broken site because of Simplenews. My site is run on Godaddy. I'm trying to find resources, but a step-by-step (or code-by-code) for getting back into my site would be appreciated.
This is remarkably frustrating...
Update: I'm not sure what's changed, but there is more to the error...
Update 2: Finally got it uninstalled. It seems to have fixed all issues.
Comment #5
avpadernoComment #6
adamps commentedI have created an issue for the underlying cause: #3190384: Route "view.simplenews_newsletters.page_1" does not exist
Comment #7
mohit.bansal623 commentedI have removed that menu.yml code as that route does not exists anywhere. After that it works fine.
Comment #9
adamps commentedThanks @mohit.bansal623 I see you posted the patch on the other issue too so let's follow up there.
Comment #10
mohit.bansal623 commentedokay @AdamPS
Comment #11
adamps commentedWas fixed in #3190384: Route "view.simplenews_newsletters.page_1" does not exist