• Advisory ID: DRUPAL-SA-2008-051
  • Project: Mailsave (third-party module)
  • Versions: 5.x and 6.x
  • Date: 2008-September-17
  • Security risk: Critical
  • Exploitable from: Remote
  • Vulnerability: Cross site scripting


Mailsave is a module that is designed to interact with mailhandler. It will detach files that are emailed to the site and save them with the node.

The module trusts the mimetype that is send with the file enabling malicious users with the ability to upload files to execute cross site scripting attacks.

Versions Affected

  • Versions of Mailsave for Drupal 5.x prior to 5.x-3.3
  • Versions of Mailsave for Drupal 6.x prior to 6.x-1.3

Drupal core is not affected. If you do not use the Mailsave module, there is nothing you need to do.


Install the latest version.

Also see the Mailsave project page.

Reported by

  • Mark Burdett (mfb)


The security contact for Drupal can be reached at security at drupal.org or via the form at http://drupal.org/contact and by selecting the security issues category.