I'm using this module on a site with Varnish.

There are problems with legal_accept path.
When Varnish is enabled, when a user try to login (after a legal change), the legal_accept page returns a 403 error, forbidden.
If I exclude Varnish, legal works, so there is something that doesn't work.
Could be the cookie?
Looking at the browser console, there are legal's cookie..

Thanks

Comments

arrubiu created an issue. See original summary.

arrubiu’s picture

Issue summary: View changes
arrubiu’s picture

I solved adding legal's cookies in the "white list" of Varnish.

  • Robert Castelo committed a102a0d on 8.x-1.x
    Issue #2998985: Legal accept not working with external cache
    
robert castelo’s picture

Component: Code » Documentation
Assigned: Unassigned » robert castelo
Status: Active » Fixed

Thanks, added a note about Varnish to the README file.

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.