We updated "entityconnect" module to "7.x-2.0-rc2" and we have deployment procedure which triggers "drush cc all" before "drush updb -y". We got next error:
$ drush cc all && drush updb -y
PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 [error]
Table 'local_dev.cache_entityconnect' doesn't exist in
/var/www/dev/docroot/includes/database/database.inc:2227
Stack trace:
#0 /var/www/dev/docroot/includes/database/database.inc(2227):
PDOStatement->execute(Array)
#1 /var/www/dev/docroot/includes/database/database.inc(697):
DatabaseStatementBase->execute(Array, Array)
#2 /var/www/dev/docroot/includes/database/query.inc(933):
The problem is that there is now any checking about existing "cache_entityconnect" table inside "entityconnect_flush_caches". This table is created in "entityconnect_update_7000" which run after "drush cc all". We propose to add checking about existing "cache_entityconnect" table inside "entityconnect_flush_caches".
Comments
Comment #2
skrasulevskiy commentedComment #3
skrasulevskiy commentedComment #5
astonvictor commentedD7 reached its EOL back in January 2025, and there is no active release for D7 for this module anymore.
Development or support is not planned for D7. All D7-related issues are marked as outdated in a bunch.